RHEL Engineering is moving the tracking of its product development work on RHEL 6 through RHEL 9 to Red Hat Jira (issues.redhat.com). If you're a Red Hat customer, please continue to file support cases via the Red Hat customer portal. If you're not, please head to the "RHEL project" in Red Hat Jira and file new tickets here. Individual Bugzilla bugs in the statuses "NEW", "ASSIGNED", and "POST" are being migrated throughout September 2023. Bugs of Red Hat partners with an assigned Engineering Partner Manager (EPM) are migrated in late September as per pre-agreed dates. Bugs against components "kernel", "kernel-rt", and "kpatch" are only migrated if still in "NEW" or "ASSIGNED". If you cannot log in to RH Jira, please consult article #7032570. That failing, please send an e-mail to the RH Jira admins at rh-issues@redhat.com to troubleshoot your issue as a user management inquiry. The email creates a ServiceNow ticket with Red Hat. Individual Bugzilla bugs that are migrated will be moved to status "CLOSED", resolution "MIGRATED", and set with "MigratedToJIRA" in "Keywords". The link to the successor Jira issue will be found under "Links", have a little "two-footprint" icon next to it, and direct you to the "RHEL project" in Red Hat Jira (issue links are of type "https://issues.redhat.com/browse/RHEL-XXXX", where "X" is a digit). This same link will be available in a blue banner at the top of the page informing you that that bug has been migrated.
Bug 1744220 - ssh prints 'no slots' when PKCS11Provider is specified, but no slot is found nor used
Summary: ssh prints 'no slots' when PKCS11Provider is specified, but no slot is found ...
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Enterprise Linux 8
Classification: Red Hat
Component: openssh
Version: 8.1
Hardware: Unspecified
OS: Unspecified
low
low
Target Milestone: rc
: 8.0
Assignee: Jakub Jelen
QA Contact: Ondrej Moriš
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2019-08-21 14:47 UTC by Ivan Nikolchev
Modified: 2021-05-03 07:54 UTC (History)
2 users (show)

Fixed In Version: openssh-8.0p1-5.el8
Doc Type: No Doc Update
Doc Text:
Clone Of:
Environment:
Last Closed: 2020-11-04 01:31:59 UTC
Type: Bug
Target Upstream Version:
Embargoed:


Attachments (Terms of Use)


Links
System ID Private Priority Status Summary Last Updated
OpenSSH Project 2610 0 None None None 2019-08-21 14:47:22 UTC
OpenSSH Project 3058 0 None None None 2019-08-23 09:20:59 UTC
Red Hat Product Errata RHBA-2020:4439 0 None None None 2020-11-04 01:32:19 UTC

Description Ivan Nikolchev 2019-08-21 14:47:23 UTC
Description of problem:
Specifying a PKCS11Provider in the configuration and using the ssh without a card inserted results in the error 'no slots'

Version-Release number of selected component (if applicable):
openssh-8.0p1-3.el8.x86_64

How reproducible:
Always

Steps to Reproduce:
1.Put 'PKCS11Provider /usr/lib/pkcs11/opensc-pkcs11.so' in ssh config
2.Try to login
3.

Actual results:
'no slots' printed

Expected results:
No error message

Additional info:
This is a regression that happened after rebase to openssh-8.0p1, it is working correctly in openssh-7.8p1-4
Original RFE - bz1372661
Upstream bug linked.

Comment 1 Jakub Jelen 2019-08-23 09:21:00 UTC
I filled a new upstream bug to address this issue.

Comment 11 errata-xmlrpc 2020-11-04 01:31:59 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory (openssh bug fix and enhancement update), and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2020:4439


Note You need to log in before you can comment on or make changes to this bug.