Bug 174432 - Unable to sync Palm Zire 72
Unable to sync Palm Zire 72
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: pilot-link (Show other bugs)
4
All Linux
medium Severity medium
: ---
: ---
Assigned To: Ivana Varekova
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2005-11-28 18:26 EST by Rodd Clarkson
Modified: 2007-11-30 17:11 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-12-01 03:56:12 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Rodd Clarkson 2005-11-28 18:26:47 EST
Description of problem:

I'm unable to sync the Palm Zire 72 on FC4.

Using >Desktop>Preferences>More Preferences>PalmOS Devices just stops after
entering all the pertinent information.

see: https://bugzilla.redhat.com/bugzilla/show_bug.cgi?id=167947

In the past this would crash (reporting problems with gpilotd), but since
updating to:

gnome-pilot-2.0.13-5.fc4.i386.rpm
gnome-pilot-devel-2.0.13-5.fc4.i386.rpm

in the fedora-testing repo, it no longer crashes, and instead just sits there
and never syncs.

Running pilot-xfer yields the following:

[rodd@localhost packages]$ ls /dev/ttyUSB*
/dev/ttyUSB0  /dev/ttyUSB1
[rodd@localhost packages]$ pilot-xfer -l -p /dev/ttyUSB1
   Unable to bind to port: /dev/ttyUSB1
   Please use --help for more information

[rodd@localhost packages]$

/dev/ttyUSB[01] appear when you first plug the Palm device in, and then on
subsequent sync requests.
Comment 1 Joe Acosta 2006-09-02 14:44:30 EDT
I'm experiencing the same thing in 2.6.17 kernel only I have a sony clie.

from dmesg it seems all is okay

usb 2-1: new full speed USB device using uhci_hcd and address 2
usb 2-1: configuration #1 chosen from 1 choice
visor 2-1:1.0: Handspring Visor / Palm OS converter detected
usb 2-1: Handspring Visor / Palm OS converter now attached to ttyUSB0
usb 2-1: Handspring Visor / Palm OS converter now attached to ttyUSB1
usb 2-1: USB disconnect, address 2
visor 2-1:1.0: device disconnected
visor ttyUSB0: Handspring Visor / Palm OS converter now disconnected from ttyUSB0
visor ttyUSB1: Handspring Visor / Palm OS converter now disconnected from ttyUSB1

Then pilot-xfer hangs at hit hotsync buton, only in order for it to get to that
message I have already hit the hotsync button.   I ran up2date last night, and
have all the updates.  It was working a few kernels ago, but its been a few
months since I've synced on Linux.  

pilot-xfer -p /dev/pilot -e /home/joeja/clie/clie.lst -b $HOME/clie

Does pilot-xfer need to be recomiled for kernel changes between 2.6.14 and 2.6.17?

/dev/pilot does appear when the hotsync button is pressed.
Comment 2 Joe Acosta 2006-10-01 16:50:58 EDT
I figured this out.  There must have been an update that screwed up permissions.
  I discovered that /dev/usbdev1.4 does not have the correct permissions for a
regular user to access.

So when I run this as root it syncs up just fine.  It think the udev rules are
screwed up.  I have noticed that somewhere along the line fedora started
shipping with a /dev/pilot in it, but it did not start out this way. It didn't
used to be this way.  

# pilot/palm devices
KERNEL=="ttyUSB*", SYSFS{product}=="Palm Handheld*", SYMLINK+="pilot"
KERNEL=="ttyUSB*", SYSFS{product}=="palmOne Handheld*", SYMLINK+="pilot"

I'm not sure, but I think it needs something that will do MODE="0666" and / or
GROUP="pdausers"  or something.



Comment 3 Ivana Varekova 2006-11-30 09:03:37 EST
Could you please try to reproduce your bug this the latest version of pilot-link
pilot-link-0.12.1-3.fc7. 
Comment 4 Rodd Clarkson 2006-11-30 15:46:42 EST
Hmmm, syncing seems to be working on FC6 with pilot-link-0.11.8-16.  (I am about
to file a bug report about evolution-data-server crashing when the sync gets to
the eCalendar stuff)

I haven't got an install of FC4 anymore.

It worked alright on FC5, but I had to edit a file (something to do with hal I
think)

Hope this helps.
Comment 5 Ivana Varekova 2006-12-01 03:56:12 EST
Thanks for your help. If you find this problem again please reopen this bug. It
would be really helpful if you fill a bug against evolution-data-server and
describe your problem. 
Comment 6 Rodd Clarkson 2006-12-05 22:51:46 EST
I'm still getting these crashed, I've files a new bug here:

see: https://bugzilla.redhat.com/bugzilla/show_bug.cgi?id=218570

Note You need to log in before you can comment on or make changes to this bug.