Bug 174435 - random crashes after time and crashes after opening new documents
random crashes after time and crashes after opening new documents
Status: CLOSED DUPLICATE of bug 171873
Product: Fedora
Classification: Fedora
Component: openoffice.org (Show other bugs)
4
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Caolan McNamara
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2005-11-28 19:24 EST by bob-lad
Modified: 2007-11-30 17:11 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-11-29 03:51:49 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description bob-lad 2005-11-28 19:24:09 EST
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.7.12) Gecko/20050922 Fedora/1.0.7-1.1.fc4 Firefox/1.0.7

Description of problem:
I see aspects of bug 171873 but also additional issues.
I get regular crashes when opening new .ods documents created in openoffice.org-2.0.0-2.  This latest crash locked X and required me to kill -9 the openoffice.org processes.  Crashed also when opening various OO.o-1.9 versions of the same file.

i did get an OO.o crash report if that helps.

0x18e028: /usr/lib/openoffice.org2.0/program/libuno_sal.so.3 + 0x1e028
0x18e7ee: /usr/lib/openoffice.org2.0/program/libuno_sal.so.3 + 0x1e7ee
0xf12420:  + 0x420 (__kernel_sigreturn + 0x0)
0x7dd2b70: /usr/lib/openoffice.org2.0/program/libvcl680li.so + 0xecb70
0x7dd427d: /usr/lib/openoffice.org2.0/program/libvcl680li.so + 0xee27d (OutputDevice::DrawRect(Rectangle const&) + 0xc5)
0x7df1794: /usr/lib/openoffice.org2.0/program/libvcl680li.so + 0x10b794
0x7df3e70: /usr/lib/openoffice.org2.0/program/libvcl680li.so + 0x10de70
0x7df3ed5: /usr/lib/openoffice.org2.0/program/libvcl680li.so + 0x10ded5 (OutputDevice::Erase() + 0x59)
0x7df4944: /usr/lib/openoffice.org2.0/program/libvcl680li.so + 0x10e944
0x7df4db0: /usr/lib/openoffice.org2.0/program/libvcl680li.so + 0x10edb0 (VirtualDevice::VirtualDevice(unsigned short) + 0x4e)
0xb3a62522: /usr/lib/openoffice.org2.0/program/libsvx680li.so + 0x2c4522
0xb3a427c1: /usr/lib/openoffice.org2.0/program/libsvx680li.so + 0x2a47c1 (EditEngine::SetRefMapMode(MapMode const&) + 0x1d)
0x9848922: /usr/lib/openoffice.org2.0/program/libsc680li.so + 0x3f6922
0x9848a92: /usr/lib/openoffice.org2.0/program/libsc680li.so + 0x3f6a92
0x97ab8df: /usr/lib/openoffice.org2.0/program/libsc680li.so + 0x3598df
0x97abdf9: /usr/lib/openoffice.org2.0/program/libsc680li.so + 0x359df9
0x9563f3b: /usr/lib/openoffice.org2.0/program/libsc680li.so + 0x111f3b
0x9563f66: /usr/lib/openoffice.org2.0/program/libsc680li.so + 0x111f66
0x7d68300: /usr/lib/openoffice.org2.0/program/libvcl680li.so + 0x82300
0x7d73dce: /usr/lib/openoffice.org2.0/program/libvcl680li.so + 0x8ddce (Timer::Timeout() + 0x10)
0x7d74148: /usr/lib/openoffice.org2.0/program/libvcl680li.so + 0x8e148
0x12abe51: /usr/lib/openoffice.org2.0/program/libvclplug_gen680li.so + 0x3ee51
0x12abe3c: /usr/lib/openoffice.org2.0/program/libvclplug_gen680li.so + 0x3ee3c (SalData::Timeout() const + 0x24)
0xf589f0: /usr/lib/openoffice.org2.0/program/libvclplug_gtk680li.so + 0x189f0
0x38a3e76: /usr/lib/libglib-2.0.so.0 + 0x24e76
0x38a235e: /usr/lib/libglib-2.0.so.0 + 0x2335e (g_main_context_dispatch + 0x1dc)
0x38a5366: /usr/lib/libglib-2.0.so.0 + 0x26366
0x38a5848: /usr/lib/libglib-2.0.so.0 + 0x26848 (g_main_context_iteration + 0x66)
0xf58bcf: /usr/lib/openoffice.org2.0/program/libvclplug_gtk680li.so + 0x18bcf
0x12b2afa: /usr/lib/openoffice.org2.0/program/libvclplug_gen680li.so + 0x45afa (X11SalInstance::Yield(unsigned char) + 0x28)
0x7d6e594: /usr/lib/openoffice.org2.0/program/libvcl680li.so + 0x88594 (Application::Yield() + 0x48)
0x7d6e5ca: /usr/lib/openoffice.org2.0/program/libvcl680li.so + 0x885ca (Application::Execute() + 0x26)
0x70bc73: /usr/lib/openoffice.org2.0/program/libsoffice.so + 0x21c73 (desktop::Desktop::Main() + 0x15ab)
0x7d7399f: /usr/lib/openoffice.org2.0/program/libvcl680li.so + 0x8d99f
0x7d73a4f: /usr/lib/openoffice.org2.0/program/libvcl680li.so + 0x8da4f (SVMain() + 0x29)
0x706ad7: /usr/lib/openoffice.org2.0/program/libsoffice.so + 0x1cad7 (sal_main + 0x57)
0x706b23: /usr/lib/openoffice.org2.0/program/libsoffice.so + 0x1cb23 (main + 0x27)
0xb24d5f: /lib/libc.so.6 + 0x14d5f (__libc_start_main + 0xdf)
0x80484c5: /usr/lib/openoffice.org2.0/program/soffice.bin + 0x4c5

Version-Release number of selected component (if applicable):
openoffice.org-core-2.0.0-3.2.1    kernel-2.6.14-1.1637_FC4

How reproducible:
Sometimes

Steps to Reproduce:
1. open file and wait
2. or open file and try to save it
3. or open file and try to edit it
  

Actual Results:  Usually it crashes resulting in the requirement for file recovery.

Expected Results:  not crashing

Additional info:

same thing happens on laptop T40, FC4 with 256M RAM also on workstation with 2G RAM, AMD XP2400+.
Comment 1 Caolan McNamara 2005-11-29 03:51:49 EST
The crash report itself is the same problem as 171873. There is a new
testing-update of 2.0.1-0.141.3.1 which you should try out to see if any
similiar problem remains.

*** This bug has been marked as a duplicate of 171873 ***

Note You need to log in before you can comment on or make changes to this bug.