Bug 1744377 - No fonts available
Summary: No fonts available
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: fontconfig
Version: 31
Hardware: x86_64
OS: Linux
unspecified
high
Target Milestone: ---
Assignee: Akira TAGOH
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
: 1744951 (view as bug list)
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2019-08-22 02:03 UTC by Steven Usdansky
Modified: 2019-09-15 00:25 UTC (History)
17 users (show)

Fixed In Version: fontconfig-2.13.92-3.fc31
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2019-09-15 00:25:45 UTC


Attachments (Terms of Use)

Description Steven Usdansky 2019-08-22 02:03:30 UTC
Description of problem: No fonts are available in GIMP 


Version-Release number of selected component (if applicable):
gimp-2.10.12-2.fc31.x86_64
system is up to date as of 21-August 2100 CDT

How reproducible:
100%


Steps to Reproduce:
1. Start GIMP, load an image or create new
2. Docked text toolbox shows "Standard" in red under font
3. Click on font selection icon
4. List is empty
5. Select text tool
6. "Standard" appears in red (without quotes)
7. Attempt to type some text
 

Actual results:
Message box - GIMP Message Due to lack of any fonts, text functionality is not available

Expected results:
Text should be drawn on the image


Additional info:
~$ rpm -qa | grep -i gtk2 | sort
adwaita-gtk2-theme-3.28-6.fc31.x86_64
gtk2-2.24.32-5.fc31.x86_64
gtk2-engines-2.20.2-19.fc31.x86_64
gtk2-immodule-xim-2.24.32-5.fc31.x86_64
pygtk2-2.24.0-26.fc31.x86_64
pygtk2-libglade-2.24.0-26.fc31.x86_64

Comment 1 Josef Ridky 2019-08-23 11:35:20 UTC
*** Bug 1744951 has been marked as a duplicate of this bug. ***

Comment 2 Josef Ridky 2019-08-27 13:09:23 UTC
The issue is caused by fontconfig package due of following commit [1].

Based on fontconfig documentation [2]:
If 'complain' is FcFalse, no warning will be displayed if 'file' does not exist.
...
Returns FcFalse if some error occurred while loading the file, either a parse error, semantic error or allocation failure. Otherwise returns FcTrue. 

Now, when 'file' is missing, FcFalse is returned instead of FcTrue and due of it, GIMP don't parse any font.conf file in the system.


Assigning this issue to fontconfig package.

[1] https://gitlab.freedesktop.org/fontconfig/fontconfig/commit/36f46ba7201481e6fee25cf3c78038d57f41d7cf
[2] https://www.freedesktop.org/software/fontconfig/fontconfig-devel/fcconfigparseandload.html

Comment 3 Fedora Update System 2019-08-28 09:19:07 UTC
FEDORA-2019-7632c79e6f has been submitted as an update to Fedora 31. https://bodhi.fedoraproject.org/updates/FEDORA-2019-7632c79e6f

Comment 4 Fedora Update System 2019-08-29 21:01:40 UTC
fontconfig-2.13.92-3.fc31 has been pushed to the Fedora 31 testing repository. If problems still persist, please make note of it in this bug report.
See https://fedoraproject.org/wiki/QA:Updates_Testing for
instructions on how to install test updates.
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2019-7632c79e6f

Comment 5 Steven Usdansky 2019-09-06 15:22:44 UTC
New fontconfig fixes the problem for me

Comment 6 Fedora Update System 2019-09-15 00:25:45 UTC
fontconfig-2.13.92-3.fc31 has been pushed to the Fedora 31 stable repository. If problems still persist, please make note of it in this bug report.


Note You need to log in before you can comment on or make changes to this bug.