This service will be undergoing maintenance at 00:00 UTC, 2016-08-01. It is expected to last about 1 hours
Bug 174440 - Review Request: bakery - C++ framework for creating GNOME apps
Review Request: bakery - C++ framework for creating GNOME apps
Status: CLOSED NEXTRELEASE
Product: Fedora
Classification: Fedora
Component: Package Review (Show other bugs)
rawhide
All Linux
medium Severity medium
: ---
: ---
Assigned To: John Mahowald
David Lawrence
http://www.poolshark.org/src/bakery-2...
:
Depends On:
Blocks: FE-ACCEPT
  Show dependency treegraph
 
Reported: 2005-11-28 21:32 EST by Denis Leroy
Modified: 2007-11-30 17:11 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-03-05 14:44:29 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Denis Leroy 2005-11-28 21:32:51 EST
Spec Name or Url: http://www.poolshark.org/src/bakery.spec
SRPM Name or Url: http://www.poolshark.org/src/bakery-2.3.15-1.src.rpm

Description:
Bakery is a C++ Framework for creating GNOME applications using gtkmm. Bakery provides a Document/View architecture, but it doesn't force you to use the whole architecture. Bakery can use XML as a Document storage format, if you like. Bakery provides default functionality, which can be easily customized, makes it easy to start developing GNOME applications and gives your application structure. Bakery also contains a few utility classes.

Note: this is targeted at FC-4 and FC-5.
Comment 1 Michael A. Peters 2005-11-28 21:50:00 EST
Not a review - but this is wrong:

* Mon Nov 28 2005 Denis Leroy <denis@poolshark.org> - 2.3.%{minor_version}-1

That will cause the %{minor_version} to be expanded in that line to a new
version when minor_version is updated - creating an incorrect changelog.
Comment 2 Denis Leroy 2005-11-28 22:44:14 EST
Yikes, absolutely! Interesting xemacs "bug".

Spec: http://www.poolshark.org/src/bakery.spec
SRPM: http://www.poolshark.org/src/bakery-2.3.15-2.src.rpm
Comment 3 Jochen Schmitt 2006-02-22 12:56:50 EST
God:
+ rpmlint of srpm ok.
+ Local build worked fine.

Bad:
- rpmlint of rpms complaints:

rpmlint bakery-2.3.15-2.i686.rpm
W: bakery incoherent-version-in-changelog 2.3.15-1 2.3.15-2

rpmlint bakery-devel-2.3.15-2.i686.rpm
W: bakery-devel doc-file-dependency
/usr/share/doc/bakery-devel-2.3.15/reference/html/installdox /usr/bin/perl

- Requires to /sbin/ldconfig are not requires.
- Requires to perl missing.
- Mock build failed:

checking pkg-config is at least version 0.9.0... yes
checking for BAKERY_CFLAGS...
checking for BAKERY_LIBS...
configure: error: Package requirements (gtkmm-2.4 >= 2.6.0 gconfmm-2.6 >= 2.6.0
libglademm-2.4 >= 2.4.0 libxml++-2.6 >= 2.8.0 gnome-vfsmm-2.6 >= 2.6.0) were not
 met.
Consider adjusting the PKG_CONFIG_PATH environment variable if you
installed software in a non-standard prefix.

Alternatively you may set the BAKERY_CFLAGS and BAKERY_LIBS environment variable
s
to avoid the need to call pkg-config.  See the pkg-config man page for
more details.
error: Bad exit status from /var/tmp/rpm-tmp.97468 (%build)



Comment 4 Denis Leroy 2006-03-01 17:21:34 EST
http://www.poolshark.org/src/bakery-2.3.15-3.src.rpm
http://www.poolshark.org/src/bakery.spec


- ldconfig deps removed
- fixed changelog
- fixed incorect gnome-vfsmm buildrequires
- worked around perl dep problem
- builds cleanly in mock

The '/usr/bin/perl' warning is interesting, since the Perl package provides
'perl', not '/usr/bin/perl'... I worked around the problem, the offending file
was only needed during doc build.

Comment 5 John Mahowald 2006-03-04 13:23:42 EST
* When creating the docs, this happened a few times:
sh: dot: command not found
Problems running dot. Check your installation!

Add graphviz as a BuildRequires and it should work.

* BuildRequires: gettext is missing (required by the %find_lang macro)
Comment 6 Denis Leroy 2006-03-04 16:09:02 EST
http://www.poolshark.org/src/bakery-2.3.17-1.src.rpm
http://www.poolshark.org/src/bakery.spec

- Update to 2.3.17 (bugfixes, more translations)
- Fixed graphviz and gettext BuildRequires
- clean mock build
- clean rpmlint
Comment 7 John Mahowald 2006-03-05 04:01:19 EST
Good:

- rpmlint checks return:

W: bakery-debuginfo objdump-failed
Executing objdump on this file failed, all checks could not be run.
Not critical

E: bakery-devel only-non-binary-in-usr-lib
There are only non binary files in /usr/lib so they should be in /usr/share.
False alarm, symlink.

- package meets naming guidelines
- package meets packaging guidelines
- license (GPL) OK, text in %doc, matches source
- spec file legible, in am. english
- source matches upstream
- package compiles on devel (x86_64)
- no missing BR
- no unnecessary BR
- locales handled by %find_lang
- not relocatable
- owns all directories that it creates
- no duplicate files
- permissions ok
- %clean ok
- macro use consistent
- code, not content
- no need for -docs
- nothing in %doc affects runtime
- no need for .desktop file

- devel package ok
- no .la files
- post/postun ldconfig ok
- devel requires base package n-v-r 

APPROVED
Comment 8 Denis Leroy 2006-03-05 14:44:29 EST
Imported and built.

Note You need to log in before you can comment on or make changes to this bug.