Bug 174445 - internal compiler error
internal compiler error
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: gcc (Show other bugs)
4
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Jakub Jelinek
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2005-11-28 23:28 EST by Rick Brown
Modified: 2007-11-30 17:11 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-12-02 05:18:01 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
The working environment (3.95 MB, application/octet-stream)
2005-11-28 23:28 EST, Rick Brown
no flags Details
Preprocessed source stored into /tmp/ccb7ZrhV.out (143.88 KB, application/octet-stream)
2005-11-29 12:03 EST, Rick Brown
no flags Details

  None (edit)
Description Rick Brown 2005-11-28 23:28:51 EST
Description of problem:
internal compiler error

Version-Release number of selected component (if applicable):
gcc-4.0.0

How reproducible:
exactly

Steps to Reproduce:
procedure to create compiler error in monttext.c
1. in a working directory tar –xzvf gcc4Bug.tar.gz
2. cd libggi-2.1.0/display/monotext
3. make –k and see compiler internal error
4. in monotext.c in the vicinity of line 78 change #if 1 to #if 0
5. make –k and see successful compile
  
Actual results:


Expected results:


Additional info:
Comment 1 Rick Brown 2005-11-28 23:28:53 EST
Created attachment 121569 [details]
The working environment
Comment 2 Jakub Jelinek 2005-11-29 04:42:12 EST
That's not the best way to report an ICE.
What you should provide instead:
- exact command line options passed to gcc (or g++, gfortran etc.) that make the
compiler ICE
- exact gcc version (4.0.0 is not exact, either provide gcc rpm NVR, or gcc -v
output)
- exact error/ICE messages gcc prints
- if the ICE reproducable, the compiler driver should have created a preprocessed
output for you and tell you where it is, so attach that file here, or you can
preprocess it manually (e.g. by adding -save-temps -v options to the
gcc/g++/whatever command line on that file) and attach the preprocessed source
here after you verify it is indeed reproducable on it.
Comment 3 Rick Brown 2005-11-29 12:03:00 EST
Created attachment 121596 [details]
Preprocessed source stored into /tmp/ccb7ZrhV.out
Comment 4 Rick Brown 2005-11-29 12:20:07 EST
That's not the best way to report an ICE.
**You are talking to a linux puppy here
exact command line options passed to gcc
**I think that may be had in ccb7ZrhV.out (attached)
exact gcc version
**4.0.0 2005019 Red Hat 4.0.0-8
exact error/ICE messages gcc prints
**Here are some notes with the prints
*************************************
Subject code at about line 78 in monotext.c
**************************************************************************
#if 0
		ascii_template[(a-32)*16 + y*accuracy.x + x] =
			count_bits(&(font_data[(a-32)*8]), x*box_w, y*box_h,
				   box_w, box_h) * 255 / (box_w*box_h);
#else
	int i = (a-32)*8;
		ascii_template[(a-32)*16 + y*accuracy.x + x] =
			count_bits(&(font_data[i]), x*box_w, y*box_h,
				   box_w, box_h) * 255 / (box_w*box_h);
#endif


*********************************************************************
Compile with #if 1
**********************************************************************
cd /home/rb/proj/LibGGI/libggi-2.1.0/display/monotext/
make -k 
if /bin/sh ../../libtool --mode=compile gcc -DHAVE_CONFIG_H -I. -I. -I../..
-I../../include   -I/usr/local/include  -g -O2 -I/usr/local/include -D_REENTRANT
-D_THREAD_SAFE -DDEBUG -g -Wall -Wpointer-arith -Wsign-compare
-Wstrict-prototypes -Wswitch -Wmissing-prototypes -Wreturn-type -Wshadow
-Wnested-externs -Wredundant-decls -Werror-implicit-function-declaration -MT
monotext.lo -MD -MP -MF ".deps/monotext.Tpo" -c -o monotext.lo monotext.c; \
then mv -f ".deps/monotext.Tpo" ".deps/monotext.Plo"; else rm -f
".deps/monotext.Tpo"; exit 1; fi
gcc -DHAVE_CONFIG_H -I. -I. -I../.. -I../../include -I/usr/local/include -g -O2
-I/usr/local/include -D_REENTRANT -D_THREAD_SAFE -DDEBUG -g -Wall
-Wpointer-arith -Wsign-compare -Wstrict-prototypes -Wswitch -Wmissing-prototypes
-Wreturn-type -Wshadow -Wnested-externs -Wredundant-decls
-Werror-implicit-function-declaration -MT monotext.lo -MD -MP -MF
.deps/monotext.Tpo -c monotext.c  -fPIC -DPIC -o monotext.lo
monotext.c: In function '_ggi_monotextOpen':
monotext.c:440: internal compiler error: in set_value_handle, at tree-vn.c:179
Please submit a full bug report,
with preprocessed source if appropriate.
See <URL:http://bugzilla.redhat.com/bugzilla> for instructions.
Preprocessed source stored into /tmp/ccb7ZrhV.out file, please attach this to
your bugreport.
make: *** [monotext.lo] Error 1
make: Target `all' not remade because of errors.

Compilation exited abnormally with code 2 at Mon Nov 28 09:54:12
************************************************************
Compiled with #if 0
***********************************************************
cd /home/rb/proj/LibGGI/libggi-2.1.0/display/monotext/
make -k 
if /bin/sh ../../libtool --mode=compile gcc -DHAVE_CONFIG_H -I. -I. -I../..
-I../../include   -I/usr/local/include  -g -O2 -I/usr/local/include -D_REENTRANT
-D_THREAD_SAFE -DDEBUG -g -Wall -Wpointer-arith -Wsign-compare
-Wstrict-prototypes -Wswitch -Wmissing-prototypes -Wreturn-type -Wshadow
-Wnested-externs -Wredundant-decls -Werror-implicit-function-declaration -MT
monotext.lo -MD -MP -MF ".deps/monotext.Tpo" -c -o monotext.lo monotext.c; \
then mv -f ".deps/monotext.Tpo" ".deps/monotext.Plo"; else rm -f
".deps/monotext.Tpo"; exit 1; fi
gcc -DHAVE_CONFIG_H -I. -I. -I../.. -I../../include -I/usr/local/include -g -O2
-I/usr/local/include -D_REENTRANT -D_THREAD_SAFE -DDEBUG -g -Wall
-Wpointer-arith -Wsign-compare -Wstrict-prototypes -Wswitch -Wmissing-prototypes
-Wreturn-type -Wshadow -Wnested-externs -Wredundant-decls
-Werror-implicit-function-declaration -MT monotext.lo -MD -MP -MF
.deps/monotext.Tpo -c monotext.c  -fPIC -DPIC -o monotext.lo
/bin/sh ../../libtool --mode=link gcc  -g -O2 -I/usr/local/include -D_REENTRANT
-D_THREAD_SAFE -DDEBUG -g -Wall -Wpointer-arith -Wsign-compare
-Wstrict-prototypes -Wswitch -Wmissing-prototypes -Wreturn-type -Wshadow
-Wnested-externs -Wredundant-decls -Werror-implicit-function-declaration 
-L/usr/local/lib -o monotext.la -rpath /usr/local/lib/ggi/display  -module
-no-undefined -avoid-version -export-symbols ./EXPSYMS color.lo draw.lo mode.lo
monotext.lo text.lo visual.lo ../../ggi/libggi.la -lgii -lgg -lm -lc 
rm -fr .libs/monotext.la .libs/monotext.* .libs/monotext.*
gcc -shared  color.lo draw.lo mode.lo monotext.lo text.lo visual.lo  -Wl,--rpath
-Wl,/home/rb/proj/LibGGI/libggi-2.1.0/ggi/.libs -Wl,--rpath -Wl,/usr/local/lib
-Wl,--rpath -Wl,/usr/local/lib  -L/usr/local/lib ../../ggi/.libs/libggi.so
/usr/local/lib/libgii.so /usr/local/lib/libgg.so -lm -lc   -Wl,-soname
-Wl,monotext.so -Wl,-retain-symbols-file -Wl,./EXPSYMS -o .libs/monotext.so
creating monotext.la
(cd .libs && rm -f monotext.la && ln -s ../monotext.la monotext.la)

Compilation finished at Mon Nov 28 09:56:17
**********************************************************************************
Let me know whatever else I can provide
-Rick
Comment 5 Jakub Jelinek 2005-12-02 05:18:01 EST
4.0.0-8 is way too old, there have been two gcc FC4 updates since FC4 was
released.  And your textcase compiles just fine with the current gcc-4.0.2-8.fc4.

Note You need to log in before you can comment on or make changes to this bug.