Bug 1744462 - [4.3] The value of the "Upgradeable" field of the "service-catalog-controller-manager" should NOT be NoData
Summary: [4.3] The value of the "Upgradeable" field of the "service-catalog-controller...
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: OpenShift Container Platform
Classification: Red Hat
Component: Service Catalog
Version: 4.3.0
Hardware: Unspecified
OS: Unspecified
medium
medium
Target Milestone: ---
: 4.3.0
Assignee: Jesus M. Rodriguez
QA Contact: Salvatore Colangelo
URL:
Whiteboard:
Depends On:
Blocks: 1755492
TreeView+ depends on / blocked
 
Reported: 2019-08-22 08:50 UTC by Jian Zhang
Modified: 2020-01-23 11:05 UTC (History)
6 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
: 1755492 (view as bug list)
Environment:
Last Closed: 2020-01-23 11:05:22 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Private Priority Status Summary Last Updated
Github openshift cluster-svcat-controller-manager-operator pull 61 0 'None' closed Bug 1744462: set Upgradeable value and other messages 2020-05-01 15:47:26 UTC
Github openshift cluster-svcat-controller-manager-operator pull 63 0 'None' closed Bug 1744462: Set upgradeable condition to true 2020-05-01 15:47:27 UTC
Red Hat Product Errata RHBA-2020:0062 0 None None None 2020-01-23 11:05:41 UTC

Description Jian Zhang 2019-08-22 08:50:55 UTC
Description of problem:
The value of the "Upgradeable" field of the "service-catalog-controller-manager" should NOT Unknown.

mac:~ jianzhang$ oc get co service-catalog-controller-manager -o yaml
...
  - lastTransitionTime: "2019-08-22T06:35:06Z"
    reason: NoData
    status: Unknown
    type: Upgradeable

Version-Release number of selected component (if applicable):
4.2.0-0.nightly-2019-08-21-235427

mac:~ jianzhang$ oc -n openshift-service-catalog-apiserver exec apiserver-xrd8s -- service-catalog --version
v4.2.0;Upstream:v0.1.42
             io.openshift.build.commit.url=https://github.com/openshift/service-catalog/commit/7d8b2a29d2e6f1daa81b9b788c944f07cf3513e1
             io.openshift.build.source-location=https://github.com/openshift/service-catalog


How reproducible:
always

Steps to Reproduce:
1. Install OCP 4.2
2. Enable Service Catalog.
3. Install a service broker. For example, ups-broker:
mac:~ jianzhang$ oc get clusterservicebroker
NAME         URL                                                        STATUS   AGE
ups-broker   http://ups-broker.kube-service-catalog.svc.cluster.local   Ready    10m
mac:~ jianzhang$ oc get clusterserviceclass
NAME                                   EXTERNAL-NAME                        BROKER       AGE
4f6e6cf6-ffdd-425f-a2c7-3c9258ad2468   user-provided-service                ups-broker   9m
5f6e6cf6-ffdd-425f-a2c7-3c9258ad2468   user-provided-service-single-plan    ups-broker   9m
8a6229d4-239e-4790-ba1f-8367004d0473   user-provided-service-with-schemas   ups-broker   9m

4, Check the ClusterOperator "service-catalog-controller-manager" status.

Actual results:
The value of the "Upgradeable" field of the "service-catalog-controller-manager" is Unknown.


Expected results:
The value of the "Upgradeable" field of the "service-catalog-controller-manager" should be True.

Additional info:
mac:~ jianzhang$ oc get co service-catalog-controller-manager -o yaml
apiVersion: config.openshift.io/v1
kind: ClusterOperator
metadata:
  creationTimestamp: "2019-08-22T06:35:06Z"
  generation: 1
  name: service-catalog-controller-manager
  resourceVersion: "53508"
  selfLink: /apis/config.openshift.io/v1/clusteroperators/service-catalog-controller-manager
  uid: fb31f931-c4a6-11e9-bed5-0050568bf2b5
spec: {}
status:
  conditions:
  - lastTransitionTime: "2019-08-22T06:35:07Z"
    reason: AsExpected
    status: "False"
    type: Degraded
  - lastTransitionTime: "2019-08-22T08:34:01Z"
    reason: AsExpected
    status: "False"
    type: Progressing
  - lastTransitionTime: "2019-08-22T08:34:56Z"
    reason: AsExpected
    status: "True"
    type: Available
  - lastTransitionTime: "2019-08-22T06:35:06Z"
    reason: NoData
    status: Unknown
    type: Upgradeable
  extension: null
  relatedObjects:
  - group: operator.openshift.io
    name: cluster
    resource: servicecatalogcontrollermanagers
  - group: ""
    name: openshift-service-catalog-controller-manager-operator
    resource: namespaces
  - group: ""
    name: openshift-service-catalog-controller-manager
    resource: namespaces
  versions:
  - name: operator
    version: 4.2.0-0.nightly-2019-08-21-235427

mac:~ jianzhang$ oc get servicecatalogcontrollermanager cluster -o yaml
apiVersion: operator.openshift.io/v1
kind: ServiceCatalogControllerManager
metadata:
  annotations:
    release.openshift.io/create-only: "true"
  creationTimestamp: "2019-08-22T06:28:39Z"
  generation: 2
  name: cluster
  resourceVersion: "53507"
  selfLink: /apis/operator.openshift.io/v1/servicecatalogcontrollermanagers/cluster
  uid: 141fae05-c4a6-11e9-8cf0-0050568b2275
spec:
  logLevel: Normal
  managementState: Managed
status:
  conditions:
  - lastTransitionTime: "2019-08-22T08:34:56Z"
    status: "True"
    type: Available
  - lastTransitionTime: "2019-08-22T08:34:01Z"
    status: "False"
    type: Progressing
  - lastTransitionTime: "2019-08-22T06:35:06Z"
    reason: Removed
    status: "False"
    type: Degraded
  - lastTransitionTime: "2019-08-22T08:33:58Z"
    status: "False"
    type: WorkloadDegraded
  generations:
  - group: apps
    hash: ""
    lastGeneration: 2
    name: controller-manager
    namespace: openshift-service-catalog-controller-manager
    resource: daemonsets
  observedGeneration: 2
  readyReplicas: 0
  version: 4.2.0-0.nightly-2019-08-21-235427

Comment 4 Salvatore Colangelo 2019-11-19 18:10:57 UTC
Hi 

below the result:

[scolange@scolange ~]$ oc get co service-catalog-controller-manager -o yaml
apiVersion: config.openshift.io/v1
kind: ClusterOperator
metadata:
  creationTimestamp: "2019-11-18T08:54:02Z"
  generation: 1
  name: service-catalog-controller-manager
  resourceVersion: "682580"
  selfLink: /apis/config.openshift.io/v1/clusteroperators/service-catalog-controller-manager
  uid: 1213c18a-051a-4790-9ea5-ccc3d4b44ca0
spec: {}
status:
  conditions:
  - lastTransitionTime: "2019-11-18T08:54:02Z"
    reason: AsExpected
    status: "False"
    type: Degraded
  - lastTransitionTime: "2019-11-19T10:28:22Z"
    reason: AsExpected
    status: "False"
    type: Progressing
  - lastTransitionTime: "2019-11-19T10:30:17Z"
    reason: AsExpected
    status: "True"
    type: Available
  - lastTransitionTime: "2019-11-18T08:54:02Z"
    reason: NoData
    status: Unknown
    type: Upgradeable
  extension: null
  relatedObjects:
  - group: operator.openshift.io
    name: cluster
    resource: servicecatalogcontrollermanagers
  - group: ""
    name: openshift-service-catalog-controller-manager-operator
    resource: namespaces
  - group: ""
    name: openshift-service-catalog-controller-manager
    resource: namespaces
  versions:
  - name: operator
    version: 4.3.0-0.nightly-2019-11-17-224250

is still present

  - lastTransitionTime: "2019-11-18T08:54:02Z"
    reason: NoData
    status: Unknown
    type: Upgradeable

Comment 5 Jesus M. Rodriguez 2019-11-20 16:20:07 UTC
I installed a fresh cluster:

$ oc version
Client Version: v4.2.0-alpha.0-273-g386b42b
Server Version: 4.3.0-0.ci-2019-11-20-134433
Kubernetes Version: v1.16.2

$ oc get co service-catalog-controller-manager -o yaml
apiVersion: config.openshift.io/v1
kind: ClusterOperator
metadata:
  creationTimestamp: "2019-11-20T15:55:43Z"
  generation: 1
  name: service-catalog-controller-manager
  resourceVersion: "9141"
  selfLink: /apis/config.openshift.io/v1/clusteroperators/service-catalog-controller-manager
  uid: 17efdd3f-2f71-4492-a8bd-4c8bf451c54e
spec: {}
status:
  conditions:
  - lastTransitionTime: "2019-11-20T15:55:43Z"
    reason: AsExpected
    status: "False"
    type: Degraded
  - lastTransitionTime: "2019-11-20T15:55:43Z"
    message: 'Progressing: the controller manager is in a removed state, therefore
      no changes are being applied.'
    reason: AsExpected
    status: "False"
    type: Progressing
  - lastTransitionTime: "2019-11-20T15:55:43Z"
    message: 'Available: the controller manager is not initially installed, operator
      is available, switch to Managed to enable.'
    reason: AsExpected
    status: "True"
    type: Available
  - lastTransitionTime: "2019-11-20T15:55:43Z"
    message: 'Upgradeable: the controller manager is in a removed state, upgrades
      are possible.'
    reason: UpgradeableRemoved
    status: "False"
    type: Upgradeable
  extension: null
  relatedObjects:
  - group: operator.openshift.io
    name: cluster
    resource: servicecatalogcontrollermanagers
  - group: ""
    name: openshift-service-catalog-controller-manager-operator
    resource: namespaces
  - group: ""
    name: openshift-service-catalog-controller-manager
    resource: namespaces
  versions:
  - name: operator
    version: 4.3.0-0.ci-2019-11-20-134433

Comment 6 Jesus M. Rodriguez 2019-11-20 16:25:38 UTC
We are now updating the field.

Comment 8 Salvatore Colangelo 2019-11-22 17:43:31 UTC
[scolange@scolange .kube]$ oc get co service-catalog-controller-manager -o yaml
apiVersion: config.openshift.io/v1
kind: ClusterOperator
metadata:
  creationTimestamp: "2019-11-21T19:25:05Z"
  generation: 1
  name: service-catalog-controller-manager
  resourceVersion: "603670"
  selfLink: /apis/config.openshift.io/v1/clusteroperators/service-catalog-controller-manager
  uid: ca4cad70-395f-4d81-a06a-5f77bb18803e
spec: {}
status:
  conditions:
  - lastTransitionTime: "2019-11-21T19:25:05Z"
    reason: AsExpected
    status: "False"
    type: Degraded
  - lastTransitionTime: "2019-11-22T17:36:05Z"
    reason: AsExpected
    status: "False"
    type: Progressing
  - lastTransitionTime: "2019-11-22T17:36:59Z"
    reason: AsExpected
    status: "True"
    type: Available
  - lastTransitionTime: "2019-11-21T19:25:05Z"
    message: 'Upgradeable: the controller manager is in a removed state, upgrades
      are possible.'
    reason: UpgradeableRemoved
    status: "False"
    type: Upgradeable
  extension: null
  relatedObjects:
  - group: operator.openshift.io
    name: cluster
    resource: servicecatalogcontrollermanagers
  - group: ""
    name: openshift-service-catalog-controller-manager-operator
    resource: namespaces
  - group: ""
    name: openshift-service-catalog-controller-manager
    resource: namespaces
  versions:
  - name: operator
    version: 4.3.0-0.nightly-2019-11-21-122827

Comment 9 Salvatore Colangelo 2019-11-22 17:44:23 UTC
[scolange@scolange .kube]$ oc get co service-catalog-controller-manager -o yaml
apiVersion: config.openshift.io/v1
kind: ClusterOperator
metadata:
  creationTimestamp: "2019-11-21T19:25:05Z"
  generation: 1
  name: service-catalog-controller-manager
  resourceVersion: "603670"
  selfLink: /apis/config.openshift.io/v1/clusteroperators/service-catalog-controller-manager
  uid: ca4cad70-395f-4d81-a06a-5f77bb18803e
spec: {}
status:
  conditions:
  - lastTransitionTime: "2019-11-21T19:25:05Z"
    reason: AsExpected
    status: "False"
    type: Degraded
  - lastTransitionTime: "2019-11-22T17:36:05Z"
    reason: AsExpected
    status: "False"
    type: Progressing
  - lastTransitionTime: "2019-11-22T17:36:59Z"
    reason: AsExpected
    status: "True"
    type: Available
  - lastTransitionTime: "2019-11-21T19:25:05Z"
    message: 'Upgradeable: the controller manager is in a removed state, upgrades
      are possible.'
    reason: UpgradeableRemoved
    status: "False"
    type: Upgradeable
  extension: null
  relatedObjects:
  - group: operator.openshift.io
    name: cluster
    resource: servicecatalogcontrollermanagers
  - group: ""
    name: openshift-service-catalog-controller-manager-operator
    resource: namespaces
  - group: ""
    name: openshift-service-catalog-controller-manager
    resource: namespaces
  versions:
  - name: operator
    version: 4.3.0-0.nightly-2019-11-21-122827

Comment 11 errata-xmlrpc 2020-01-23 11:05:22 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2020:0062


Note You need to log in before you can comment on or make changes to this bug.