Bug 174449 - Installer does not paint screen when loading
Installer does not paint screen when loading
Product: Fedora
Classification: Fedora
Component: xorg-x11-drv-i810 (Show other bugs)
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Mike A. Harris
Depends On:
  Show dependency treegraph
Reported: 2005-11-29 00:35 EST by Ryan Claeys
Modified: 2007-11-30 17:11 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Last Closed: 2006-02-21 06:10:11 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---

Attachments (Terms of Use)
xorg.conf file after installation (2.79 KB, text/plain)
2006-02-03 00:18 EST, Ryan Claeys
no flags Details
Xorg.0.log created from trying to startX (62.50 KB, text/plain)
2006-02-03 00:19 EST, Ryan Claeys
no flags Details
Log file created from trying to run system-config-display (838 bytes, text/plain)
2006-02-03 00:25 EST, Ryan Claeys
no flags Details

  None (edit)
Description Ryan Claeys 2005-11-29 00:35:13 EST
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.7.12) Gecko/20050915 Firefox/1.0.7

Description of problem:
When installing on my Laptop  (wxga screen) when the graphical interface loads the screen turns and stays black.
It is not hung or crashed, as can be determined by pressing the tab key.  Pressing the tab changes focus on the buttons and causes the buttons to repaint and display.  I can actually navigate with the buttons and can tell I get to the next screens as the buttons change.
I tried attaching an external monitor to the laptop and obtained the same error.
I tried setting resolution to various values with resolution=
I tried using the nofb parameter
All brought about the same error

Version-Release number of selected component (if applicable):

How reproducible:

Steps to Reproduce:
1.Insert installation CD
2.Follow prompts until graphical installer starts

Actual Results:  Screen is black.  Buttons can be made appear by pressing tab to change focus.

Expected Results:  Full screen of graphical installer should be visible.

Additional info:
Comment 1 Jeremy Katz 2005-11-30 22:38:41 EST
Does X work after the install? 
Comment 2 Ryan Claeys 2005-12-01 09:19:38 EST
I have been unable to complete an install since linux text does not work (see
bug 160660/ 174448) and I haven't had a chance to try the work around for it,
and navigating the installer in graphical mode with a mostly black screen is a
Comment 3 Jeremy Katz 2005-12-01 11:31:21 EST
Does it help if you boot with resolution= passing whatever the native resolution
of your LCD is?
Comment 4 Ryan Claeys 2005-12-01 14:28:22 EST
Tried resoloution=1280x800 which should be my native resolution.
Here are my hardware specs
Comment 5 Jeremy Katz 2005-12-01 14:36:51 EST
If you have another machine, you should be able to pass 'vnc' on the command
line to do a VNC install as a workaround.  But this sounds like the newer X not
liking your video chip.
Comment 6 Ryan Claeys 2005-12-03 13:43:17 EST
Not sure if this is related or not, but when I try to do the 'vnc' install,  the
vnc client has just a black screen.  (tabbing etc, does not make buttons appear)

The laptop screen shows.  (prior to starting VNC)  Probing for video card: 
Intel Corporation 82852/855GM Integrated Graphics Device

When VNC Starts.
_X11TransSocketINETConnect() can't get address for localhost:6001: Name or
service not known

(mini-wm:577): Gtk-WARNING **: cannot open display:  :1
Comment 7 Mike A. Harris 2006-01-31 13:44:51 EST
If you haven't installed already, please do a text mode install, and then
run system-config-display --reconfig manually.  Once you've installed,
update to the latest packages available in Fedora devel.  If the problem
persists, please attach your X server log file and config file as individual
uncompressed file attachments.

Comment 8 Ryan Claeys 2006-02-02 13:50:52 EST
Just tried on FC5 test 2.  Problem still exists.

Attempted to do a text install.  System hangs on Dependency Check.  I tried
removing all the RPM's it still hangs there.

Going to try to do a VNC install and see if that allows me to install or if the
problem I had with that still remains.

Will let you know if I get anywhere or not.

Comment 9 Ryan Claeys 2006-02-03 00:18:38 EST
Created attachment 124086 [details]
xorg.conf file after installation
Comment 10 Ryan Claeys 2006-02-03 00:19:56 EST
Created attachment 124087 [details]
Xorg.0.log  created from trying to startX
Comment 11 Ryan Claeys 2006-02-03 00:25:11 EST
Created attachment 124088 [details]
Log file created from trying to run system-config-display

I was able to install FC5 test 2 using VNC installation.  I then booted to a
console.  Ran yum groupinstall "X Window System"

startx	gave me a blank screen
system-config-display  gave me the same blank screen

I have added my xorg.conf file and  my log files as requested.	
Comment 12 Mike A. Harris 2006-02-08 06:51:47 EST
Update your system to the latest Fedora devel packages, including the kernel
and reboot into the new kernel and test it again to see if the problem has
disappeared in the latest packages.  Once you've tried this, please update
the report with your results, and indicate the version of the various
X rpms that are installed:  rpm -qa |grep ^xorg-x11 | sort
Comment 13 Mike A. Harris 2006-02-21 06:10:11 EST
Fedora Core 5 test3 has been released.  Please update to the latest test
release and if the problem is still present, please file a bug report in
X.Org bugzilla at http://bugs.freedesktop.org in the "xorg" component.
Be sure to attach your current X server log, config file and all details
directly to the X.Org bugzilla so that the upstream driver maintainers
have as many details as possible in order to the issue.

Once you've filed your bug report to X.Org, if you paste the new
bug URL here, Red Hat will continue to track the issue in the
centralized X.Org bug tracker, and will review any bug fixes
that become available for consideration in future updates.

Setting status to "RAWHIDE"

Note You need to log in before you can comment on or make changes to this bug.