Bug 1744952 - Boot freezes on fedora logo
Summary: Boot freezes on fedora logo
Keywords:
Status: CLOSED DUPLICATE of bug 1490490
Alias: None
Product: Fedora
Classification: Fedora
Component: kernel
Version: 30
Hardware: x86_64
OS: Linux
unspecified
unspecified
Target Milestone: ---
Assignee: Kernel Maintainer List
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2019-08-23 10:48 UTC by Honza Brázdil
Modified: 2019-08-24 12:45 UTC (History)
17 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2019-08-24 12:45:37 UTC
Type: Bug


Attachments (Terms of Use)
journalctl --no-hostname -b -1 (272.52 KB, text/plain)
2019-08-23 10:48 UTC, Honza Brázdil
no flags Details

Description Honza Brázdil 2019-08-23 10:48:56 UTC
Created attachment 1607278 [details]
journalctl --no-hostname -b -1

1. Please describe the problem:
I just upgraded from F29 to F30. After reboot booting gets stuck on the Fedora logo. Booting with older kernel from F29 works.


2. What is the Version-Release number of the kernel:
5.2.9-200.fc30.x86_64


3. Did it work previously in Fedora? If so, what kernel version did the issue
   *first* appear?  Old kernels are available for download at
   https://koji.fedoraproject.org/koji/packageinfo?packageID=8 :
It worked in F29 and booting works if I use the F29 kernel 5.2.7-100.fc29.x86_64


4. Can you reproduce this issue? If so, please provide the steps to reproduce
   the issue below:
 1: Boot


5. Does this problem occur with the latest Rawhide kernel? To install the
   Rawhide kernel, run ``sudo dnf install fedora-repos-rawhide`` followed by
   ``sudo dnf update --enablerepo=rawhide kernel``:


6. Are you running any modules that not shipped with directly Fedora's kernel?:
Not to my knowledge

7. Please attach the kernel logs. You can get the complete kernel log
   for a boot with ``journalctl --no-hostname -k > dmesg.txt``. If the
   issue occurred on a previous boot, use the journalctl ``-b`` flag.

Comment 1 Honza Brázdil 2019-08-23 11:17:00 UTC
I tried to install 5.2.7-200.fc30.x86_64 and it also doesn't boot. Maybe it's some other component then kernel?

Comment 2 Hans de Goede 2019-08-23 13:56:28 UTC
Try pressing "ESC" while on the Fedora logo, or removoing "quiet rhgb" from the kernel commandline to get the bootup messages, these will hopefully provide more info.

Comment 3 Honza Brázdil 2019-08-23 23:55:10 UTC
Interesting, removing the "rhgb" makes it boot fine. 

With "rhgb" on it freezes just when the logo appears before it starts to fill up. ESC does nothing nor does ctrl-alt-del (which sometimes works for the reboot I think).

Comment 4 Hans de Goede 2019-08-24 12:45:37 UTC
I see from your attached journal that you are using a Gigabyte Z77X-UD3H motherboard with a radeon card using the amdgpu driver through adding the following on the kernel commandline: "radeon.cik_support=0 amdgpu.cik_support=1 amdgpu.dc=1"

So this appears to be a duplicate of bug 1490490, I have fixing bug 1490490 on my TODO list, I hope to be able to start working on it 2 weeks from now. In the mean time you can use not having rhgb on the kernel commandline as a workaround, that or drop "radeon.cik_support=0 amdgpu.cik_support=1 amdgpu.dc=1" (which is not supported) from your kernel commandline.

*** This bug has been marked as a duplicate of bug 1490490 ***


Note You need to log in before you can comment on or make changes to this bug.