Bug 1744984 - KCM cannot recover from deleting its lease configmap
Summary: KCM cannot recover from deleting its lease configmap
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: OpenShift Container Platform
Classification: Red Hat
Component: kube-controller-manager
Version: 4.2.0
Hardware: Unspecified
OS: Unspecified
medium
medium
Target Milestone: ---
: 4.4.0
Assignee: Mike Dame
QA Contact: zhou ying
URL:
Whiteboard:
Depends On:
Blocks: 1718061 1780843 1781240
TreeView+ depends on / blocked
 
Reported: 2019-08-23 12:30 UTC by Michal Fojtik
Modified: 2020-05-04 11:13 UTC (History)
9 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of: 1718061
: 1780843 (view as bug list)
Environment:
Last Closed: 2020-05-04 11:13:08 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Github openshift cluster-kube-controller-manager-operator pull 311 'None' 'open' 'Bug 1744984: Add e2e test for kube controller manager lease configmap deletion' 2019-12-07 16:03:02 UTC
Red Hat Product Errata RHBA-2020:0581 None None None 2020-05-04 11:13:35 UTC

Comment 1 Mike Dame 2019-12-05 22:01:31 UTC
I've created an e2e test and updated the RBAC rules which I believe fix this issue, and allow the configmap to be automatically recreated upon deletion. Should this bug be updated to target 4.4 for the PR to merge, or should I clone it to 4.4?

Comment 3 zhou ying 2019-12-16 05:38:40 UTC
Confirmed with payload: 4.4.0-0.nightly-2019-12-15-184910, the issue has fixed:

[root@dhcp-140-138 ~]# oc  get cm -n kube-system
NAME                                 DATA   AGE
bootstrap                            1      117m
cluster-config-v1                    1      126m
extension-apiserver-authentication   6      126m
kube-controller-manager              0      126m
root-ca                              1      126m
[root@dhcp-140-138 ~]# oc delete cm/kube-controller-manager  -n kube-system
configmap "kube-controller-manager" deleted
[root@dhcp-140-138 ~]# oc get cm -n kube-system
NAME                                 DATA   AGE
bootstrap                            1      118m
cluster-config-v1                    1      126m
extension-apiserver-authentication   6      126m
kube-controller-manager              0      11s
root-ca                              1      126m

Comment 5 errata-xmlrpc 2020-05-04 11:13:08 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2020:0581


Note You need to log in before you can comment on or make changes to this bug.