Bug 174507 - Xvfb has wrong font path hard coded
Xvfb has wrong font path hard coded
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: xorg-x11-server (Show other bugs)
rawhide
All Linux
medium Severity medium
: ---
: ---
Assigned To: Mike A. Harris
:
Depends On:
Blocks: FC5Blocker
  Show dependency treegraph
 
Reported: 2005-11-29 11:34 EST by Tim Waugh
Modified: 2007-11-30 17:11 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-02-21 09:19:05 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Tim Waugh 2005-11-29 11:34:00 EST
Description of problem:
Xvfb fails to start.

Version-Release number of selected component (if applicable):
xorg-x11-server-Xvfb-0.99.3-9

How reproducible:
100%

Steps to Reproduce:
1. Xvfb :5
  
Actual results:
Could not init font path element /usr/lib/X11/fonts/misc/, removing from list!
Could not init font path element /usr/lib/X11/fonts/TTF/, removing from list!
Could not init font path element /usr/lib/X11/fonts/OTF, removing from list!
Could not init font path element /usr/lib/X11/fonts/Type1/, removing from list!
Could not init font path element /usr/lib/X11/fonts/CID/, removing from list!
Could not init font path element /usr/lib/X11/fonts/100dpi/, removing from
list!Could not init font path element /usr/lib/X11/fonts/75dpi/, removing from list!

Fatal server error:
could not open default font 'fixed'
Comment 1 Tim Waugh 2005-11-29 13:09:21 EST
Looks like xorg-x11-server's configure.ac needs this change at line 346:

-FONTDIR="${libdir}/X11/fonts"
+FONTDIR="${datadir}/X11/fonts"

Not sure if that fixes it?
Comment 2 Mike A. Harris 2006-02-21 05:44:41 EST
Same issue for Xnest:

https://bugzilla.redhat.com/bugzilla/show_bug.cgi?id=174484
Comment 3 Mike A. Harris 2006-02-21 09:19:05 EST
# rpm -q xorg-x11-server-Xvfb
xorg-x11-server-Xvfb-1.0.1-6
# strings /usr/bin/Xvfb |grep /usr
/usr/share/X11/rgb
/usr/share/X11/fonts/misc/,/usr/share/X11/fonts/TTF/,/usr/share/X11/fonts/OTF,/usr/share/X11/fonts/Type1/,/usr/share/X11/fonts/CID/,/usr/share/X11/fonts/100dpi/,/usr/share/X11/fonts/75dpi/
/usr/lib/xserver/SecurityPolicy
/usr/bin
/usr/share/X11/xkb
/usr/adm/X%smsgs


Appears to be fixed in RAWHIDE.

Note You need to log in before you can comment on or make changes to this bug.