Bug 1745146 - Report Template "Applicable Errata" fails for large numbers of Content Hosts
Summary: Report Template "Applicable Errata" fails for large numbers of Content Hosts
Keywords:
Status: CLOSED WONTFIX
Alias: None
Product: Red Hat Satellite
Classification: Red Hat
Component: Reporting
Version: 6.5.0
Hardware: All
OS: Linux
urgent
high vote
Target Milestone: Unspecified
Assignee: Ondřej Ezr
QA Contact: Lukáš Hellebrandt
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2019-08-23 17:37 UTC by Dylan Gross
Modified: 2022-09-19 14:50 UTC (History)
9 users (show)

Fixed In Version:
Doc Type: Known Issue
Doc Text:
Clone Of:
Environment:
Last Closed: 2022-09-19 14:50:33 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Private Priority Status Summary Last Updated
Foreman Issue Tracker 29970 0 Normal Closed Report Template "Applicable Errata" fails for large numbers of Content Hosts 2021-12-02 03:29:05 UTC

Description Dylan Gross 2019-08-23 17:37:19 UTC
Description of problem:

  The "Applicable Errata" report template fails when run against a large number of hosts.  (Approximately 17,000).   It runs for about 12 hours, until it finally ends with a "500 Internal Server error".  (Maybe that 12 hours is a timeout wall?)

  When smaller numbers 

Version-Release number of selected component (if applicable):

  Red Hat Satellite 6.5.2

How reproducible:
Steps to Reproduce:
1.   In the WebUI:  "Monitor"->"Report Templates"->"Applicable Errata"
2.   In the Hosts Filter, specify a search string to match a large number of hosts.  Leave errata filter blank
3.   Submit

Actual results:

   Small numbers return in reasonable amount of time
   Large searches take impossibly long to report

Expected results:

   Reports generate or at least complete in reasonable amount of time.  (i.e. not erroring after 12 hours of waiting to return)

Comment 15 Shira Maximov 2020-06-01 10:24:56 UTC
Created redmine issue https://projects.theforeman.org/issues/29970 from this bug

Comment 18 Bryan Kearney 2020-10-12 20:05:12 UTC
Upstream bug assigned to oezr

Comment 19 Bryan Kearney 2020-10-12 20:05:15 UTC
Upstream bug assigned to oezr

Comment 23 Bryan Kearney 2021-11-22 16:01:29 UTC
Moving this bug to POST for triage into Satellite since the upstream issue https://projects.theforeman.org/issues/29970 has been resolved.

Comment 26 Ondřej Ezr 2022-01-26 22:08:53 UTC
This was missaligned upstream as it was not closed by the merge and only got aligned to 3.2, but actually landed in 2.3, so it is already included in Sat 6.9

Comment 32 thadzhie 2022-09-19 14:50:33 UTC
We have considered this BZ during a triage and since some work has already been done and no feedback has been received, we consider the work being done enough.


Note You need to log in before you can comment on or make changes to this bug.