Bug 1745178 - nova notifications need to be enabled when novjoin is enabled
Summary: nova notifications need to be enabled when novjoin is enabled
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat OpenStack
Classification: Red Hat
Component: openstack-tripleo-heat-templates
Version: 15.0 (Stein)
Hardware: Unspecified
OS: Unspecified
high
high
Target Milestone: rc
: 15.0 (Stein)
Assignee: Alex Schultz
QA Contact: Pavan
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2019-08-23 19:00 UTC by Ade Lee
Modified: 2019-09-27 10:44 UTC (History)
6 users (show)

Fixed In Version: openstack-tripleo-heat-templates-10.6.1-0.20190826150036.30390bc.el8ost
Doc Type: No Doc Update
Doc Text:
Clone Of:
Environment:
Last Closed: 2019-09-21 11:24:25 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Private Priority Status Summary Last Updated
OpenStack gerrit 678288 0 None stable/stein: NEW tripleo-heat-templates: Explicitly set notification driver for novajoin (Ifee8f7f50fc2ef99605cbbcaa89016514b80b561) 2019-08-26 14:55:48 UTC
Red Hat Product Errata RHEA-2019:2811 0 None None None 2019-09-21 11:25:00 UTC

Description Ade Lee 2019-08-23 19:00:39 UTC
Description of problem:

Recently, a change was made to disable notifications when telemetry was disabled.
Unfortunately this does not account for novajoin-notifier, which listens to notifications from nova to be able to determine when servers are deleted so it can update IPA accordingly.
 

Version-Release number of selected component (if applicable):


How reproducible:


Steps to Reproduce:
1.
2.
3.

Actual results:


Expected results:


Additional info:

Comment 5 Grzegorz Grasza 2019-09-04 15:28:00 UTC
To verify this,
* deploy tripleo with "TLS everywhere"
* list hosts in IPA
* delete one of the overcloud openstack server instances
* lists hosts in IPA - the host should be removed
* there should be "Delete host ..." entry in novajoin-notifier logs, with info level

Alternatively, the whole deployment could be deleted - the hosts should also be removed from IPA.

Comment 11 errata-xmlrpc 2019-09-21 11:24:25 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHEA-2019:2811


Note You need to log in before you can comment on or make changes to this bug.