Bug 1745199 - Running 'systemctl isolate' on any target disconnects any active sessions, including sending signal 15 to ssh sessions from other users.
Summary: Running 'systemctl isolate' on any target disconnects any active sessions, in...
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Enterprise Linux 7
Classification: Red Hat
Component: systemd
Version: 7.6
Hardware: Unspecified
OS: Linux
urgent
urgent
Target Milestone: rc
: ---
Assignee: David Tardon
QA Contact: Frantisek Sumsal
URL:
Whiteboard:
: 1743416 1745788 1748188 1761748 (view as bug list)
Depends On:
Blocks: 1751130
TreeView+ depends on / blocked
 
Reported: 2019-08-23 21:13 UTC by Tom Crider
Modified: 2020-07-03 11:35 UTC (History)
16 users (show)

Fixed In Version: systemd-219-70.el7
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
: 1751130 (view as bug list)
Environment:
Last Closed: 2020-03-31 20:02:28 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Github systemd systemd issues 1969 'None' closed systemctl isolate causes forced logout 2020-07-03 11:28:26 UTC
Red Hat Product Errata RHBA-2020:1117 None None None 2020-03-31 20:03:05 UTC

Description Tom Crider 2019-08-23 21:13:07 UTC
Description of problem:
Running 'systemctl isolate' on any target disconnects any active sessions, including sending signal 15 to ssh sessions from other users.

Version-Release number of selected component (if applicable):

In RHEL 7.6 + RHEL 7.7
systemd.x86_64 0:219-67.el7_7.1
systemd-sysv.x86_64 0:219-67.el7_7.1           
systemd-libs.x86_64 0:219-67.el7_7.1
libgudev1.x86_64 0:219-67.el7_7.1

In RHEL 7.7 you must also downgrade:
systemd-python.x86_64 0:219-67.el7_7.1

How reproducible:

Consistently

Steps to Reproduce:

In a fresh RHEL 7.6 VM: 
1) run # yum update
2) create test accounts.
3) login to all sessions and a root session via ssh in multiple terminals
4) In the root terminal run # systemctl isolate multi-user.target 
5) Watch everyone get disconnected.

Actual results:

Test session 1:

$ ssh test1@192.168.122.4
test1@192.168.122.4's password: 

After issuing isolate on root session:

[test1@localhost ~]$ Connection to 192.168.122.4 closed by remote host.
Connection to 192.168.122.4 closed.

Test session 2:

$ ssh test2@192.168.122.4
test2@192.168.122.4's password: 

After issuing isolate on root session:

[test2@localhost ~]$ Connection to 192.168.122.4 closed by remote host.
Connection to 192.168.122.4 closed.

Root Session:

$ ssh root@192.168.122.4
root@192.168.122.4's password: 
Last login: Fri Aug 23 16:52:31 2019 from gateway

[root@localhost ~]# systemctl isolate multi-user.target
Connection to 192.168.122.4 closed by remote host.
Connection to 192.168.122.4 closed.

Expected results:

[root@localhost ~]# systemctl isolate multi-user.target
[root@localhost ~]# 

(no session disconnects)

Additional info:

Running the following to downgrade packages resolves the issue as a workaround:

RHEL 7.6:
# yum downgrade systemd systemd-sysv systemd-libs libgudev1

RHEL 7.7:
# yum downgrade systemd systemd-sysv systemd-libs libgudev1 systemd-python

Comment 2 Tom Crider 2019-08-23 21:25:15 UTC
Additional note: This does not happen on RHEL 8

Comment 3 David Tardon 2019-08-27 07:51:33 UTC
*** Bug 1745788 has been marked as a duplicate of this bug. ***

Comment 6 David Tardon 2019-08-27 12:29:09 UTC
PR: https://github.com/systemd-rhel/rhel-7/pull/38

Comment 7 David Tardon 2019-08-27 13:49:51 UTC
*** Bug 1743416 has been marked as a duplicate of this bug. ***

Comment 9 Lukáš Nykrýn 2019-09-02 10:36:00 UTC
fix merged to github master branch -> https://github.com/systemd-rhel/rhel-7/pull/38 -> post

Comment 10 David Tardon 2019-09-06 12:50:53 UTC
*** Bug 1748188 has been marked as a duplicate of this bug. ***

Comment 14 Tru Huynh 2019-09-22 15:56:39 UTC
https://bugs.centos.org/view.php?id=16438 as quick and dirty, "works for me" while waiting for a definitive solution

Comment 16 aihua liang 2019-10-15 10:24:06 UTC
*** Bug 1761748 has been marked as a duplicate of this bug. ***

Comment 19 errata-xmlrpc 2020-03-31 20:02:28 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2020:1117


Note You need to log in before you can comment on or make changes to this bug.