Bug 1745241 - [4.1] must-gather isn't collecting controllerconfig/machine-config-operator
Summary: [4.1] must-gather isn't collecting controllerconfig/machine-config-operator
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: OpenShift Container Platform
Classification: Red Hat
Component: Machine Config Operator
Version: 4.1.z
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
: 4.1.z
Assignee: Antonio Murdaca
QA Contact: Robert Fairley
URL:
Whiteboard:
Depends On: 1745240
Blocks:
TreeView+ depends on / blocked
 
Reported: 2019-08-24 09:07 UTC by Antonio Murdaca
Modified: 2019-09-12 18:56 UTC (History)
3 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of: 1745240
Environment:
Last Closed: 2019-09-12 18:56:13 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Github openshift machine-config-operator pull 1088 None None None 2019-08-30 12:18:03 UTC
Red Hat Product Errata RHBA-2019:2681 None None None 2019-09-12 18:56:19 UTC

Description Antonio Murdaca 2019-08-24 09:07:02 UTC
+++ This bug was initially created as a clone of Bug #1745240 +++

Description of problem:

must-gather isn't collecting the controllerconfig/machine-config-controller object. That object is listed in the RelatedObjects for the clusteroperator. The issue behind that is that the name we use is wrong:

$ oc describe co/machine-config
  Related Objects:
    ...
    Group:     machineconfiguration.openshift.io
    Name:      cluster
    Resource:  controllerconfigs

The name of the resource isn't "cluster" but "machine-config-controller"

Version-Release number of selected component (if applicable):

4.2


How reproducible:

always


Steps to Reproduce:
1. run must-gather
2. 
3.

Actual results:

controllerconfig/machinie-config-controller object isn't included


Expected results:

controllerconfig/machinie-config-controller _is_ included aiding debugging


Additional info:

Comment 4 Robert Fairley 2019-09-06 14:48:05 UTC
Verified on `4.1.0-0.nightly-2019-09-05-023547`.

- oc describe co/machine-config
Related Objects:
    Group:     machineconfiguration.openshift.io
    Name:      machine-config-controller
    Resource:  controllerconfigs

- look for machine-config-controller.yaml in must-gather logs
cluster-scoped-resources/machineconfiguration.openshift.io/controllerconfigs/machine-config-controller.yaml

Comment 6 errata-xmlrpc 2019-09-12 18:56:13 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2019:2681


Note You need to log in before you can comment on or make changes to this bug.