Bug 1745321 - Move postfix-pcre, postfix-cdb, postfix-sqlite to AppStream repository
Summary: Move postfix-pcre, postfix-cdb, postfix-sqlite to AppStream repository
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Enterprise Linux 8
Classification: Red Hat
Component: postfix
Version: 8.0
Hardware: Unspecified
OS: Unspecified
unspecified
medium
Target Milestone: rc
: 8.0
Assignee: Jaroslav Škarvada
QA Contact: Patrik Moško
Mariya Pershina
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2019-08-25 11:49 UTC by Morten Stevens
Modified: 2020-05-12 10:17 UTC (History)
15 users (show)

Fixed In Version: postfix-3.3.1-10.el8
Doc Type: Bug Fix
Doc Text:
.PCRE, CDB, and SQLite can now be used with Postfix In RHEL 8, the `postfix` package has been split into multiple subpackages, each subpackage providing a plug-in for a specific database. Previously, RPM packages containing the `postfix-pcre`, `postfix-cdb`, and `postfix-sqlite` plug-ins were not distributed. Consequently, databases with these plug-ins could not be used with Postfix. This update adds RPM packages containing the PCRE, CDB, and SQLite plug-ins to the AppStream repository. As a result, these plug-ins can be used after the appropriate RPM package is installed.
Clone Of:
Environment:
Last Closed: 2020-04-28 16:47:16 UTC
Type: Bug
Target Upstream Version:
apmukher: needinfo-


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Red Hat Knowledge Base (Solution) 4788421 None None None 2020-04-15 18:34:44 UTC
Red Hat Product Errata RHBA-2020:1816 None None None 2020-04-28 16:47:20 UTC

Description Morten Stevens 2019-08-25 11:49:05 UTC
Description of problem:

Postfix does not support PCRE on RHEL8.

Version-Release number of selected component (if applicable):

postfix-3.3.1-8.el8.x86_64


Steps to Reproduce:
1. postconf -m

Actual results:

# postconf -m
btree
cidr
environ
fail
hash
inline
internal
memcache
nis
pipemap
proxy
randmap
regexp
socketmap
static
tcp
texthash
unionmap
unix


Expected results:

PCRE support

Comment 6 bugzilla-redhat-com 2019-11-05 21:49:05 UTC
Somehow, this does not look like a model solution, but it seems to work. I my case, I downloaded latest fedora 29 versions of
- libicu
- postfix
- postfix-pcre
- postfix-ldap
and installed with

  yum localinstall *.rpm

Then I added to /etc/yum.conf

  exclude=libicu,postfix*

to avoid any update conflicts. Hope this get's fixed fast. Thanks

Comment 20 bwalton 2020-04-20 12:49:32 UTC
I see there is a knowledge base article now linked to this bug report.  When I click on it, I get access denied.  Is that intentional?

Comment 22 errata-xmlrpc 2020-04-28 16:47:16 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2020:1816


Note You need to log in before you can comment on or make changes to this bug.