Bug 174533 - Redundant ownership of base system dirs in all libX* and xorg-x11* packages
Redundant ownership of base system dirs in all libX* and xorg-x11* packages
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: xorg-x11 (Show other bugs)
rawhide
All Linux
medium Severity medium
: ---
: ---
Assigned To: X/OpenGL Maintenance List
: Reopened
Depends On:
Blocks: FC5Target
  Show dependency treegraph
 
Reported: 2005-11-29 14:57 EST by Ville Skyttä
Modified: 2008-06-14 10:06 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-06-14 10:06:27 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Ville Skyttä 2005-11-29 14:57:29 EST
It seems that all (well, _many_) libX* and xorg-x11* packages in Rawhide
redundantly own %{_mandir}, which is already owned by the filesystem package:

    $ grep -l '^%dir %{_mandir}$' libX*/*.spec xorg*/*.spec | wc -l
    79

Fix:

    sed -i -e '/^%dir %{_mandir}$/d' libX*/*.spec xorg*/*.spec

:)
Comment 1 Mike A. Harris 2005-11-29 19:19:23 EST
This is intentional.
Comment 2 Ville Skyttä 2005-11-29 20:15:14 EST
Could you elaborate?  Oh... I see it's also done for /etc in some cases and
/usr/share and /usr/lib (but not for /usr or /).

All these dirs are already owned by the filesystem package which cannot be
removed, so what value does owning them add?
Comment 3 Mike A. Harris 2005-11-29 22:03:43 EST
What problem does specifying them cause?  Nothing.
Comment 4 Tom "spot" Callaway 2005-11-29 23:11:52 EST
Reopening, until mharris can provide a good reason why he is dual-owning
anything that filesystem owns besides *X11* (which xorg should own somehow). ;)
Comment 5 Ville Skyttä 2005-12-20 11:42:46 EST
No changes in 1.0.0-*, it seems.  (See also comment 4; I never received an email
notification about that being added.)
Comment 6 Tom "spot" Callaway 2005-12-20 15:59:56 EST
Apparently, the owner of these packages sees no reason to be reasonable and use
best practices when making clean rpm specs.

I can't force him to do it, however, Fedora Extras packagers should not do what
this packager has done in Fedora Core.
Comment 7 Mike A. Harris 2006-02-02 01:18:40 EST
Update:

I've discussed this request with Tom via email just prior to Christmas,
intending to clarify any confusion over the matter, and to try and ensure
we're seeing eye to eye.

I promised that I would re-evaluate the problem in the future, but also
indicated that there were a number of higher priorities to be considered
beforehand.  About a month or so has elapsed now, and it's time to
address this issue now and move forward.

For the benefit of everyone reading this, I'd like to clarify a few things.

Purely on technical grounds, it is my opinion that all packages should
technically own every directory that they place files in, and all directories
leading up to that.  I do have a good technical rationale for this opinion,
of which I have expressed in IRC, and have discussed with Tom, Jeff Johnson,
and various others.

While I am not the only person who shares this technical opinion rather
strongly, I think it is much more important to have a final resolution
to the issue, and move forward, than to risk getting caught up unnecessarily
in a heated technical debate over a trivial issue, with people whom I
respect.  Also, while comment #6 did rather offend me initially, I
understand that it was likely said in the heat of the moment at the
time, and I harbour no ill feelings about it currently.  I'd much
rather share beers at OLS while we joke about it and razz each other.  ;o)

On technical grounds, while I do still disagree about the issue, and there
do not appear to be any strict policies for Fedora Core which require
such, I have decided to put my technical opinion aside, and go ahead and
implement the requested changes, as I think we can all easily agree that
getting closure on trivial issues of this nature is more important, even
if there is technical disagreement or conflicts of opinion.

Therefore, I have started removing directory ownership from X packaging,
where the directories are common system directories such as %{_mandir}
and similar.  Since this is being done manually as I make updates to
the packages and fix bugs, etc. it will likely take a while to completely
resolve the issue as you've requested.  I'm currently updating all of
the driver packages, which should be done tomorrow or the next day.

After that, if anyone feels like providing a complete list here of remaining
packages that need to be updated yet, I'll cross them off the list as I
go along, until it's complete.  Otherwise, I'll get to them all eventually,
as I spot them when going through the packages.

Overall, I think this decision is rather reasonable, if not overly so. ;o)

Anyhow, we can all now concentrate on bigger and better things, without
having curled feathers.  ;o)

Peace.
Comment 8 Mike A. Harris 2006-02-02 04:10:03 EST
Modulo human error, all of the input driver packages have been updated for
this change.  More to come...
Comment 9 Mike A. Harris 2006-02-03 02:21:55 EST
All video driver packages updated.
Comment 10 Mike A. Harris 2006-02-06 03:49:56 EST
xorg-x11-server 1.0.1-3 and later should be clean when built
Comment 11 Mike A. Harris 2006-02-16 18:05:02 EST
Fixed xorg-x11-proto-devel-7.0-3
Comment 12 Mike A. Harris 2006-03-01 02:20:34 EST
The remainder of the X11R7 spec files have been updated in CVS to remove
ownership of system dirs.  A few have been rebuilt with other fixes for
rawhide already.  The others will pick up the changes the next time there
is good reason to rebuild the package.

Closing as RAWHIDE

Note You need to log in before you can comment on or make changes to this bug.