Bug 1745636 - unable to update nodejs/npm due to conflict with libnghttp2
Summary: unable to update nodejs/npm due to conflict with libnghttp2
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: nodejs
Version: 29
Hardware: x86_64
OS: Linux
unspecified
medium
Target Milestone: ---
Assignee: NodeJS Packaging SIG
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2019-08-26 14:33 UTC by Scott R. Godin
Modified: 2020-11-05 10:34 UTC (History)
6 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2019-08-27 18:37:50 UTC
Type: Bug


Attachments (Terms of Use)

Description Scott R. Godin 2019-08-26 14:33:37 UTC
Description of problem:
10:25 AM {1009} localhost: ~>$ sudo dnf list updates
[sudo] password for webdragon: 
Last metadata expiration check: 0:10:33 ago on Mon 26 Aug 2019 10:15:42 AM EDT.
Available Upgrades
nodejs.x86_64                                                                1:10.16.3-1.fc29                                                                    updates
nodejs-libs.x86_64                                                           1:10.16.3-1.fc29                                                                    updates
npm.x86_64                                                                   1:6.9.0-1.10.16.3.1.fc29                                                            updates
10:26 AM {1010} localhost: ~>$ dnf update 
Error: This command has to be run under the root user.
10:26 AM {1011} localhost: ~>$ sudo !!
10:26 AM {1011} localhost: ~>$ sudo dnf update 
Last metadata expiration check: 0:10:47 ago on Mon 26 Aug 2019 10:15:42 AM EDT.
Dependencies resolved.

 Problem 1: package nodejs-1:10.16.3-1.fc29.x86_64 requires libnghttp2 >= 1.39.2, but none of the providers can be installed
  - cannot install the best update candidate for package nodejs-1:10.16.0-3.fc29.x86_64
  - package libnghttp2-1.39.2-1.module_f29+5959+e526a653.x86_64 is excluded
 Problem 2: package npm-1:6.9.0-1.10.16.3.1.fc29.x86_64 requires nodejs = 1:10.16.3-1.fc29, but none of the providers can be installed
  - package nodejs-1:10.16.3-1.fc29.i686 requires libnghttp2 >= 1.39.2, but none of the providers can be installed
  - package nodejs-1:10.16.3-1.fc29.x86_64 requires libnghttp2 >= 1.39.2, but none of the providers can be installed
  - cannot install the best update candidate for package npm-1:6.9.0-1.10.16.0.3.fc29.x86_64
  - package libnghttp2-1.39.2-1.module_f29+5959+e526a653.x86_64 is excluded
 Problem 3: package nodejs-1:10.16.0-3.fc29.x86_64 requires nodejs-libs(x86-64) = 1:10.16.0-3.fc29, but none of the providers can be installed
  - problem with installed package nodejs-1:10.16.0-3.fc29.x86_64
  - cannot install both nodejs-libs-1:10.16.3-1.fc29.x86_64 and nodejs-libs-1:10.16.0-3.fc29.x86_64
  - package nodejs-1:10.16.3-1.fc29.x86_64 requires libnghttp2 >= 1.39.2, but none of the providers can be installed
  - cannot install the best update candidate for package nodejs-libs-1:10.16.0-3.fc29.x86_64
  - package libnghttp2-1.39.2-1.module_f29+5959+e526a653.x86_64 is excluded
  - package nodejs-1:10.16.3-1.module_f29+5959+e526a653.x86_64 is excluded
  - package nodejs-1:11.14.0-2.module_f29+4062+460da852.x86_64 is excluded
  - package nodejs-1:12.6.0-1.module_f29+5189+da5ff9fb.x86_64 is excluded
========================================================================================================================================================================
 Package                                Architecture                      Version                                              Repository                          Size
========================================================================================================================================================================
Skipping packages with conflicts:
(add '--best --allowerasing' to command line to force their upgrade):
 nodejs-libs                            x86_64                            1:10.16.3-1.fc29                                     updates                            8.7 M
Skipping packages with broken dependencies:
 nodejs                                 i686                              1:10.16.3-1.fc29                                     updates                            100 k
 nodejs                                 x86_64                            1:10.16.3-1.fc29                                     updates                            100 k
 npm                                    x86_64                            1:6.9.0-1.10.16.3.1.fc29                             updates                            3.8 M

Transaction Summary
========================================================================================================================================================================
Skip  4 Packages

Nothing to do.
Complete!



Version-Release number of selected component (if applicable):

Installed Packages
nodejs.x86_64  1:10.16.0-3.fc29
npm.x86_64     1:6.9.0-1.10.16.0.3.fc29

How reproducible:
every time

Steps to Reproduce:
1. have ndejs 1:10.16.0-3.fc29 and npm 1:6.9.0-1.10.16.0.3.fc29 installed
2. dnf update


Actual results:
cannot update

Expected results:
update successful

Additional info:
steam is not installed so I do not believe that is the issue with the conflict on libnghttp2

Comment 1 Fedora Update System 2019-08-26 20:29:28 UTC
FEDORA-2019-8a437d5c2f has been submitted as an update to Fedora 29. https://bodhi.fedoraproject.org/updates/FEDORA-2019-8a437d5c2f

Comment 2 Fedora Update System 2019-08-27 18:37:50 UTC
nghttp2-1.39.2-1.fc29 has been pushed to the Fedora 29 stable repository. If problems still persist, please make note of it in this bug report.


Note You need to log in before you can comment on or make changes to this bug.