Description of problem:
The patch 00329-fips.patch adds hashlib.get_fips_mode(). Please rename the new function to _get_fips_mode(). It's an internal helper and should not be part of public API for hashlib module.
Version-Release number of selected component (if applicable):
I'm thinking aboutl not re-exporting it from hashlib, and keeping it as _hashlib.get_fips_mode. _hashlib itself is an internal helper.
Does that sound OK?
Does it has to be a function or can you make it an attribute of _hashlib?
Ergonomics don't matter for internal helpers, so I'll keep it as a function call.
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.
For information on the advisory, and where to find the updated
files, follow the link below.
If the solution does not work for you, open a new bug report.