Bug 174581 - Bootsector written to device first detected by anaconda, not root-partition chosen by kickstart-option 'part --ondisk'
Bootsector written to device first detected by anaconda, not root-partition c...
Status: CLOSED DUPLICATE of bug 174580
Product: Red Hat Enterprise Linux 3
Classification: Red Hat
Component: anaconda (Show other bugs)
3.0
i386 Linux
medium Severity low
: ---
: ---
Assigned To: Jeremy Katz
Mike McLean
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2005-11-30 08:12 EST by Christian Horn
Modified: 2007-11-30 17:07 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-11-30 10:59:25 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Christian Horn 2005-11-30 08:12:40 EST
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.7.12) Gecko/20050922 Firefox/1.0.7 (Debian package 1.0.7-1)

Description of problem:
A server with fiber-hba (driver lpfc) and hardware-raid (driver cciss) get booted by a kickstart-cd (RHEL3u6) and get installed. The drivers are loaded in that order, via lpfc san-storage gets detected and available as /dev/sda, then the hardware-raid is found.
ks.cfg has 'part / --fstype ext3 --size=1500 --ondisk=cciss/c0d0 --asprimary' and the system gets installed onto the internal disks, however the bootsector gets written to /dev/sda . After reboot system fails in starting the bootloader.
Usage of lilo or grub makes no difference.

Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1.boot system from kickstart-cd
2.complete networkinstallation
3.reboot system
  

Actual Results:  After reboot system fails in starting the bootloader. System prints the values of cpu-registers and freezes.

Expected Results:  Start of bootloader.

Additional info:

Workaround:
Configure ks.cfg to use lilo and 'interactive, run installation as usual.
When system is installed and waits for the user to hit return for the final reboot change to console2 (<ALT>+<F2>) and:
chroot /mnt/sysimage
vi etc/lilo.conf # and change '/dev/sda' into '/dev/cciss/c0d0'
sbin/lilo # write correct bootblock

reboot.
Comment 1 Jeremy Katz 2005-11-30 10:59:25 EST

*** This bug has been marked as a duplicate of 174580 ***

Note You need to log in before you can comment on or make changes to this bug.