Bug 1745818 - [virtio-win][netkvm] It shows wrong name for "TesOnly.RXThrottle" on Win7 and Win2008R2
Summary: [virtio-win][netkvm] It shows wrong name for "TesOnly.RXThrottle" on Win7 and...
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Enterprise Linux 8
Classification: Red Hat
Component: virtio-win
Version: 8.0
Hardware: Unspecified
OS: Unspecified
low
low
Target Milestone: rc
: 8.2
Assignee: Yan Vugenfirer
QA Contact: Yu Wang
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2019-08-27 03:01 UTC by Yu Wang
Modified: 2020-04-28 16:06 UTC (History)
4 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2020-04-28 16:05:15 UTC
Type: Bug
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Red Hat Product Errata RHEA-2020:1757 None None None 2020-04-28 16:06:07 UTC

Description Yu Wang 2019-08-27 03:01:26 UTC
Description of problem:


Version-Release number of selected component (if applicable):
virtio-win-prewhql-173



How reproducible:
100%

Steps to Reproduce:
1. boot guest with virtio-net device
2. 
Registration in NetSH (instllation):
1).cmd --> run as administrator
2).cd path-to-the-netkvm-driver
3).# rundll32 netkvmco.dll,RegisterNetKVMNetShHelper

3. netsh netkvm show parameters name

4. check "TesOnly.RXThrottle"

Actual results:
It shows "NumberOfHandledRXPackersInDPC"

Expected results:

Should be "NumberOfHandledRXPacketsInDPC"

Packers-->Packets


Additional info:
it shows correct for win8+ guests

Comment 1 Yan Vugenfirer 2019-10-22 08:20:34 UTC
https://github.com/virtio-win/kvm-guest-drivers-windows/pull/406

1. There was a typo in the parameter name shown to the user.

2. In general "TesOnly.X" parameters are not shown to the user and can only be set by changing registry directly. It was done in order not to confuse the users with debug settings. For some reason "TesOnly.RXThrottle" was kept in INF.

3. The fix removes "TesOnly.RXThrottle" from the GUI settings. It still can be set in the registry if needed.

4. The verification after the fix should test that the "TesOnly.RXThrottle" is not shown in the device manager after the driver is installed.

Comment 2 Yu Wang 2019-12-13 09:20:22 UTC
Verified on latest driver (virtio-win-prewhql-174)
Guest OS: win7-74, win8-32, win2016 and win2019

"TesOnly.RXThrottle" is not shown in the device manager and  no "NumberOfHandledRXPackersInDPC" after typing "netsh netkvm show parameters name"

So this bug has been fixed , I will change it to verified.


Thanks
Yu Wang

Comment 8 errata-xmlrpc 2020-04-28 16:05:15 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHEA-2020:1757


Note You need to log in before you can comment on or make changes to this bug.