Bug 174591 - xchat-gnome lacks ability to accept self-signed certificates
Summary: xchat-gnome lacks ability to accept self-signed certificates
Status: CLOSED NEXTRELEASE
Alias: None
Product: Fedora
Classification: Fedora
Component: xchat-gnome   
(Show other bugs)
Version: 4
Hardware: All Linux
medium
medium
Target Milestone: ---
Assignee: Brian Pepple
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Keywords: FutureFeature
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2005-11-30 15:17 UTC by Josh Boyer
Modified: 2007-11-30 22:11 UTC (History)
2 users (show)

Fixed In Version:
Doc Type: Enhancement
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-12-30 18:10:42 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
GNOME Bugzilla 322848 None None None Never

Description Josh Boyer 2005-11-30 15:17:04 UTC
Description of problem:

There is no option in xchat-gnome to accept self-signed ssl certificates.  This
is needed when attempting to use SSL to connect to a private IRC network, etc. 
X-Chat proper has this as an option ("Accept invalid SSL certificate").

Version-Release number of selected component (if applicable):

xchat-gnome-0.6.5.fc4.i386.rpm

How reproducible:

Always

Comment 1 Guillaume Desmottes 2005-12-28 20:21:19 UTC
I wrote a patch in upstream to implement this feature.
If it's possible could you test it please ? (or provide a server with invalid
SSL certificate).

See: http://bugzilla.gnome.org/show_bug.cgi?id=322848

Comment 2 Brian Pepple 2005-12-30 01:20:20 UTC
Guillaume's patch has been applied upstream.

Once I get some free time, I'll finish working on 0.8 for Rawhide (currently
failing to build, I'm assuming due to modular X), and I'll include this patch.

Comment 3 Brian Pepple 2005-12-30 18:10:42 UTC
New package should be available once it's been signed.


Note You need to log in before you can comment on or make changes to this bug.