Bug 174600 - install-time kbd settings don't propagate to installed image
install-time kbd settings don't propagate to installed image
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: anaconda (Show other bugs)
5
All Linux
medium Severity medium
: ---
: ---
Assigned To: Chris Lumens
Mike McLean
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2005-11-30 12:06 EST by Alexandre Oliva
Modified: 2007-11-30 17:11 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-12-01 13:44:19 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Alexandre Oliva 2005-11-30 12:06:00 EST
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux x86_64; en-US; rv:1.8) Gecko/20051118 Fedora/1.5-0.5.0.rc3 Firefox/1.5

Description of problem:
The keyboard selection chosen at install time (booted from boot.iso CD) does not seem to affect in any way the installed filesystem.  E.g., I selected us-acentos, which used to map to us_intl in X, but /etc/X11/xorg.conf has "us" as the keyboard layout, and the text-mode keyboard setting is `us'.

Since firstboot doesn't ask for keyboard configuration either, you end up with a system that is very difficult to use if your keyboard does not follow the US layout, which makes it difficult to even log in to fix that.

Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1.Select keyboard settings other than US
2.Perform install

Actual Results:  The selection does not propagate to the installed system

Expected Results:  There should be some way to get the correct settings to the installed system

Additional info:

Note You need to log in before you can comment on or make changes to this bug.