Bug 174601 - can't choose runtime language nor translations
can't choose runtime language nor translations
Status: CLOSED NOTABUG
Product: Fedora
Classification: Fedora
Component: anaconda (Show other bugs)
5
All Linux
medium Severity medium
: ---
: ---
Assigned To: Jeremy Katz
Mike McLean
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2005-11-30 12:11 EST by Alexandre Oliva
Modified: 2007-11-30 17:11 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-11-30 22:33:52 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Alexandre Oliva 2005-11-30 12:11:16 EST
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux x86_64; en-US; rv:1.8) Gecko/20051118 Fedora/1.5-0.5.0.rc3 Firefox/1.5

Description of problem:
The language chosen at install time claims to not affect anything but the install interaction language, which is fine.  However, there is not any way to select the set of languages that the installed system should support, nor what its default language should be.  In particular, an interactive install with all package group buttons selected results in an install that supports only US English.

Since firstboot doesn't ask for language configuration either, you end up with a system that is very difficult to use for speakers of any other language.

Version-Release number of selected component (if applicable):


How reproducible:
Didn't try

Steps to Reproduce:
1.Select English as the install language
2.Perform install

Actual Results:  No translations are installed, run-time language is en_US.UTF-8

Expected Results:  There should be a way to select the run-time language, and if it's in firstboot, then firstboot should be available in all languages and ask the user which language to use as the first thing.

Additional info:
Comment 1 Jeremy Katz 2005-11-30 22:33:52 EST
The install-time language sets the default runtime language.  When package
selection comes back, you'll be able to select additional languages there just
like you could in FC4.  You might have noticed the text at the top of that
screen saying that it was just a placeholder while we were making the major
backend changes.

Note You need to log in before you can comment on or make changes to this bug.