Bugzilla (bugzilla.redhat.com) will be under maintenance for infrastructure upgrades and will not be available on July 31st between 12:30 AM - 05:30 AM UTC. We appreciate your understanding and patience. You can follow status.redhat.com for details.
Bug 1746019 - [osp] Machines should have event
Summary: [osp] Machines should have event
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: OpenShift Container Platform
Classification: Red Hat
Component: Cloud Compute
Version: 4.2.0
Hardware: Unspecified
OS: Unspecified
medium
medium
Target Milestone: ---
: 4.2.0
Assignee: Mike Fedosin
QA Contact: sunzhaohua
URL:
Whiteboard: osp
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2019-08-27 13:30 UTC by sunzhaohua
Modified: 2019-10-16 06:38 UTC (History)
4 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2019-10-16 06:37:54 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Private Priority Status Summary Last Updated
Github openshift cluster-api-provider-openstack pull 63 0 None None None 2019-09-10 09:49:43 UTC
Red Hat Product Errata RHBA-2019:2922 0 None None None 2019-10-16 06:38:05 UTC

Description sunzhaohua 2019-08-27 13:30:20 UTC
Description of problem:
Machines should have event

Version-Release number of selected component (if applicable):
4.2.0-0.nightly-2019-08-22-153337

How reproducible:
always

Steps to Reproduce:
1. Create a new machine
2. Check event
3.

Actual results:

$ oc describe machine shared-jiazha-8ck2c-worker1-sbvz7
Status:
  Addresses:
    Address:     192.168.0.45
    Type:        InternalIP
    Address:     shared-jiazha-8ck2c-worker1-sbvz7
    Type:        Hostname
    Address:     shared-jiazha-8ck2c-worker1-sbvz7
    Type:        InternalDNS
  Last Updated:  2019-08-27T05:48:12Z
  Node Ref:
    Kind:  Node
    Name:  shared-jiazha-8ck2c-worker1-sbvz7
    UID:   29138f7d-c88e-11e9-a9fb-fa163e210871
Events:    <none>

Expected results:
Machines have events.

Additional info:

Comment 1 Mike Fedosin 2019-09-06 12:24:19 UTC
After the discussions with PMs we decided not to implement this in 4.2, because there is a workaround to define OPENSHIFT_INSTALL_OS_IMAGE_OVERRIDE variable which allows to set another glance image name. This is explained in the user documentation.

And in 4.3 we're going to implement auto image uploading, where installer automatically creates an image in glance. so all this image stuff will be hidden from users and they don't have to specify the image name at all.

Comment 2 Mike Fedosin 2019-09-06 12:26:08 UTC
Oops, put comment to a wrong bug... Reopened it

Comment 6 sunzhaohua 2019-09-12 02:40:36 UTC
Verified.

$ ./oc get clusterversion
NAME      VERSION                             AVAILABLE   PROGRESSING   SINCE   STATUS
version   4.2.0-0.nightly-2019-09-11-202233   True        False         48m     Cluster version is 4.2.0-0.nightly-2019-09-11-202233

$ ./oc get event | grep zhsun-8p6x5-worker-aaa
35m         Normal    Created             machine/zhsun-8p6x5-worker-aaa                      Created Machine zhsun-8p6x5-worker-aaa
36s         Normal    Deleted             machine/zhsun-8p6x5-worker-aaa                      Node "zhsun-8p6x5-worker-aaa" drained
17s         Normal    Deleted             machine/zhsun-8p6x5-worker-aaa                      Deleted machine zhsun-8p6x5-worker-aaa

Comment 7 errata-xmlrpc 2019-10-16 06:37:54 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2019:2922


Note You need to log in before you can comment on or make changes to this bug.