Bug 1746119 - Installer fails to create a cluster on GCP when using N2 machine type with allow_stopping_for_update set to false
Summary: Installer fails to create a cluster on GCP when using N2 machine type with al...
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: OpenShift Container Platform
Classification: Red Hat
Component: Installer
Version: 4.2.0
Hardware: Unspecified
OS: All
unspecified
high
Target Milestone: ---
: 4.2.0
Assignee: Patrick Dillon
QA Contact: Weihua Meng
URL:
Whiteboard: aos-scalability-42
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2019-08-27 17:30 UTC by Naga Ravi Chaitanya Elluri
Modified: 2019-10-16 06:38 UTC (History)
3 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2019-10-16 06:37:54 UTC
Target Upstream Version:


Attachments (Terms of Use)
Install log (118.40 KB, text/plain)
2019-08-27 17:30 UTC, Naga Ravi Chaitanya Elluri
no flags Details
Sample install config (679 bytes, text/plain)
2019-08-27 17:57 UTC, Naga Ravi Chaitanya Elluri
no flags Details


Links
System ID Priority Status Summary Last Updated
Github openshift installer pull 2325 None None None 2019-09-06 14:57:30 UTC
Red Hat Product Errata RHBA-2019:2922 None None None 2019-10-16 06:38:05 UTC

Description Naga Ravi Chaitanya Elluri 2019-08-27 17:30:09 UTC
Created attachment 1608690 [details]
Install log

Description of problem:
The installer fails with the following error when trying to create a cluster on GCP using N2 machine type:

level=error msg="Error: Changing the machine_type, min_cpu_platform, or service_account on an instance requires stopping it. To acknowledge this, please set allow_stopping_for_update = true in your config."

Version-Release number of the following components:
root@ip-172-31-66-170: ~/scale-ci-deploy # bin/openshift-install version
bin/openshift-install v4.2.0-201908201019-dirty
built from commit c2bdbb618c25500e2fa4602c73c506358cc59ae7
release image registry.svc.ci.openshift.org/ocp/release@sha256:d0bc8d66b0ed4d5b4f2da5a1fb93e0589b88c5fcf94763bb8b56b0f022b3f51d

Payload: registry.svc.ci.openshift.org/ocp/release:4.2.0-0.nightly-2019-08-20-162755

How reproducible:
Always

Steps to Reproduce:
1. Set the machine type of Masters and Workers to N2. The zones need to be us-central1-a and us-central1-c as they are only zones which support N2 instances.
2. Install the cluster.

Actual results:
Error: Changing the machine_type, min_cpu_platform, or service_account on an instance requires stopping it. To acknowledge this, please set allow_stopping_for_update = true in your config.

Expected results:
Cluster installed successfully.

Additional info:
Attached the openshift install log.

Comment 1 Abhinav Dahiya 2019-08-27 17:37:34 UTC
Looking at the logs, it looks like we are trying to modify the instances during bootstrap destroy.

1) we should identify why there is a change on these master machines, nothing should be changing for them..
2) maybe fix the issue for now with lifecycle options https://www.terraform.io/docs/configuration/resources.html#lifecycle-lifecycle-customizations

Comment 2 Naga Ravi Chaitanya Elluri 2019-08-27 17:57:41 UTC
Created attachment 1608691 [details]
Sample install config

Comment 6 Weihua Meng 2019-09-12 13:12:39 UTC
Fixed.

4.2.0-0.nightly-2019-09-12-072817

Install cluster success with n2-standard-4 type

Comment 7 errata-xmlrpc 2019-10-16 06:37:54 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2019:2922


Note You need to log in before you can comment on or make changes to this bug.