Bug 1746230 - GCP: master machine objects missing target pools
Summary: GCP: master machine objects missing target pools
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: OpenShift Container Platform
Classification: Red Hat
Component: Installer
Version: 4.2.0
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
: 4.2.0
Assignee: Michael Gugino
QA Contact: Weihua Meng
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2019-08-28 03:46 UTC by Michael Gugino
Modified: 2019-10-16 06:38 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2019-10-16 06:38:11 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Github openshift installer pull 2276 None None None 2019-08-28 03:49:56 UTC
Red Hat Product Errata RHBA-2019:2922 None None None 2019-10-16 06:38:24 UTC

Description Michael Gugino 2019-08-28 03:46:35 UTC
Description of problem:

GCP master machine objects missing targetPools.  These are created by the installer.  We need these to be present to allow for automated remediation in the future.  AWS has proper lb's configured on master machine objects, we need to do the same in other providers.

How reproducible: 100%

Steps to Reproduce:
1. Install GCP cluster
2. Inspect machine objects for masters.

Actual results:
No entry for targetPools.

Expected results:
targetPools are present.

Comment 1 Michael Gugino 2019-08-28 03:51:03 UTC
PR Created: https://github.com/openshift/installer/pull/2276

Comment 5 Weihua Meng 2019-08-31 03:19:39 UTC
targetPools not found.
will check with new build later.

oc adm release extract --command=openshift-install registry.svc.ci.openshift.org/ocp/release:4.2.0-0.nightly-2019-08-30-142130
 
./openshift-install version
./openshift-install v4.2.0-201908282219-dirty
built from commit 4f3e73a0143ba36229f42e8b65b6e65342bb826b
release image registry.svc.ci.openshift.org/ocp/release@sha256:1f44f2932dd4c85bd9e70445b4e699796e033ced1fde7f9da534c344da118278


[weihuameng@dhcp-140-6 4.2.0-20190829]$ ./oc get machine wmeng3-q9q7r-m-0 -o yaml | grep -i target
[weihuameng@dhcp-140-6 4.2.0-20190829]$ ./oc get clusterversion
NAME      VERSION                             AVAILABLE   PROGRESSING   SINCE   STATUS
version   4.2.0-0.nightly-2019-08-30-142130   True        False         72m     Cluster version is 4.2.0-0.nightly-2019-08-30-142130
[weihuameng@dhcp-140-6 4.2.0-20190829]$ ./oc get machine wmeng3-q9q7r-m-0 -o yaml 
apiVersion: machine.openshift.io/v1beta1
kind: Machine
metadata:
  annotations:
    machine.openshift.io/instance-state: RUNNING
  creationTimestamp: "2019-08-31T00:08:49Z"
  finalizers:
  - machine.machine.openshift.io
  generation: 2
  labels:
    machine.openshift.io/cluster-api-cluster: wmeng3-q9q7r
    machine.openshift.io/cluster-api-machine-role: master
    machine.openshift.io/cluster-api-machine-type: master
    machine.openshift.io/instance-type: n1-standard-4
    machine.openshift.io/region: us-central1
    machine.openshift.io/zone: us-central1-a
  name: wmeng3-q9q7r-m-0
  namespace: openshift-machine-api
  resourceVersion: "3703"
  selfLink: /apis/machine.openshift.io/v1beta1/namespaces/openshift-machine-api/machines/wmeng3-q9q7r-m-0
  uid: 81fb0823-cb83-11e9-9174-42010a000005
spec:
  metadata:
    creationTimestamp: null
  providerID: gce://openshift-qe/us-central1-a/wmeng3-q9q7r-m-0
  providerSpec:
    value:
      apiVersion: gcpprovider.openshift.io/v1beta1
      canIPForward: false
      credentialsSecret:
        name: gcp-cloud-credentials
      deletionProtection: false
      disks:
      - autoDelete: true
        boot: true
        image: wmeng3-q9q7r-rhcos-image
        labels: null
        sizeGb: 128
        type: pd-ssd
      kind: GCPMachineProviderSpec
      machineType: n1-standard-4
      metadata:
        creationTimestamp: null
      networkInterfaces:
      - network: wmeng3-q9q7r-network
        subnetwork: wmeng3-q9q7r-master-subnet
      projectID: openshift-qe
      region: us-central1
      serviceAccounts:
      - email: wmeng3-q9q7r-m@openshift-qe.iam.gserviceaccount.com
        scopes:
        - https://www.googleapis.com/auth/cloud-platform
      tags:
      - wmeng3-q9q7r-master
      userDataSecret:
        name: master-user-data
      zone: us-central1-a
status:
  addresses:
  - address: 10.0.0.4
    type: InternalIP
  - address: wmeng3-q9q7r-m-0.us-central1-a.c.openshift-qe.internal
    type: InternalDNS
  - address: wmeng3-q9q7r-m-0.c.openshift-qe.internal
    type: InternalDNS
  lastUpdated: "2019-08-31T00:10:40Z"
  nodeRef:
    kind: Node
    name: wmeng3-q9q7r-m-0.c.openshift-qe.internal
    uid: 757f2e73-cb83-11e9-9174-42010a000005
  providerStatus:
    conditions:
    - lastProbeTime: "2019-08-31T00:10:39Z"
      lastTransitionTime: "2019-08-31T00:10:39Z"
      message: machine successfully created
      reason: MachineCreationSucceeded
      status: "True"
      type: MachineCreated
    instanceId: wmeng3-q9q7r-m-0
    instanceState: RUNNING
    metadata:
      creationTimestamp: null

Comment 6 Weihua Meng 2019-09-03 13:19:25 UTC
Fixed.

./openshift-install version
./openshift-install v4.2.0
built from commit 8c9abe40f7616303c03cafdc9ad612cd8fa7bd6b
release image registry.svc.ci.openshift.org/ocp/release@sha256:f50e4440df6a933df2b3e6976dd5ec9e14955bbb778d011f7bad6bdbb1d26686

$ oc get clusterversion
NAME      VERSION                             AVAILABLE   PROGRESSING   SINCE   STATUS
version   4.2.0-0.nightly-2019-09-02-172410   True        False         156m    Cluster version is 4.2.0-0.nightly-2019-09-02-172410


      Tags:
        wmeng7-ths5r-master
      Target Pools:
        wmeng7-ths5r-ign
        wmeng7-ths5r-api
      User Data Secret:
        Name:  master-user-data
      Zone:    us-central1-a

Comment 7 errata-xmlrpc 2019-10-16 06:38:11 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2019:2922


Note You need to log in before you can comment on or make changes to this bug.