Bug 174629 - diskless patches do not apply correctly
diskless patches do not apply correctly
Status: CLOSED ERRATA
Product: Red Hat Enterprise Linux 4
Classification: Red Hat
Component: system-config-netboot (Show other bugs)
4.0
All Linux
medium Severity medium
: ---
: ---
Assigned To: Radek Vokal
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2005-11-30 16:04 EST by David Barksdale
Modified: 2008-07-24 15:32 EDT (History)
0 users

See Also:
Fixed In Version: RHBA-2008-0672
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-07-24 15:32:57 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
patch to fix patches for rhel4.7 (8.56 KB, patch)
2008-02-07 10:21 EST, Radek Brich
no flags Details | Diff

  None (edit)
Description David Barksdale 2005-11-30 16:04:50 EST
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.7.12) Gecko/20050915 Firefox/1.0.7

Description of problem:
When running 'mkdiskless' in order to prepare an NFS root filesystem for diskless booting, several patches are applied to files in '/etc/rc.d'. These patches fail to apply with the following errors:

patching file /targetfs/rh-cpm1/root/etc/rc.d/rc.sysinit
Hunk #1 FAILED at 243.
Hunk #2 FAILED at 322.
Hunk #3 FAILED at 339.
Hunk #4 FAILED at 808.
4 out of 4 hunks FAILED -- saving rejects to file /targetfs/rh-cpm1/root/etc/rc.d/rc.sysinit.rej
patching file /targetfs/rh-cpm1/root/etc/init.d/halt
Hunk #1 succeeded at 25 with fuzz 2.
patching file /targetfs/rh-cpm1/root/etc/init.d/netfs
Hunk #1 FAILED at 23.
Hunk #2 FAILED at 90.
2 out of 2 hunks FAILED -- saving rejects to file /targetfs/rh-cpm1/root/etc/init.d/netfs.rej
patching file /targetfs/rh-cpm1/root/etc/init.d/xfs
Hunk #1 FAILED at 56.
Hunk #2 succeeded at 104 (offset 22 lines).
1 out of 2 hunks FAILED -- saving rejects to file /targetfs/rh-cpm1/root/etc/init.d/xfs.rej

Version-Release number of selected component (if applicable):
system-config-netboot-0.1.32-1_EL4

How reproducible:
Always

Steps to Reproduce:
1. Follow the steps in the Red Hat Enterprise Linux System Administration Guide to setup a diskless boot environment
2. Look for failed patch attempts (.rej files) in your NFS root filesystem

Additional info:
Comment 1 Jason Vas Dias 2005-11-30 18:37:45 EST
Yes, some initscripts have changed drastically since the patches were 
generated. 

In practice, however, the failed patches do not lead to any problems 
with diskless client booting - I've not found any problems caused by
the mis-patched initscripts so far. If you do, please append details to this
bug report.

The whole idea of patching initscripts during mkdiskless is wrong - it 
should probably replace the initscripts by installing a 'diskless-initscripts'
rpm , or by making initscripts which accept options for diskless environments
so they don't need to be patched / replaced.

I'll remove the patches from the next release and look into implementing
one of the above options.
Comment 2 David Barksdale 2005-12-01 10:13:00 EST
I have not experienced any problems booting with the failed patches. Perhaps the
severity of this bug should be lower?
In any case, I think creating initscripts that can handle both environments
would be the best solution.
Thank you.
Comment 3 Fedora Update System 2006-03-01 17:00:55 EST
From User-Agent: XML-RPC

system-config-netboot-0.1.38-2_FC4 has been pushed for FC4, which should resolve this issue.  If these problems are still present in this version, then please make note of it in this bug report.
Comment 4 Radek Brich 2008-02-07 10:21:53 EST
Created attachment 294214 [details]
patch to fix patches for rhel4.7

The patches updated for latest init scripts in RHEL4. This maybe isn't
necessary, but it's much nicer when the patches do not fail and do not leave
ugly .rej files throughout rc.d.
Comment 5 RHEL Product and Program Management 2008-02-07 10:27:19 EST
This request was evaluated by Red Hat Product Management for inclusion in a Red
Hat Enterprise Linux maintenance release.  Product Management has requested
further review of this request by Red Hat Engineering, for potential
inclusion in a Red Hat Enterprise Linux Update release for currently deployed
products.  This request is not yet committed for inclusion in an Update
release.
Comment 12 errata-xmlrpc 2008-07-24 15:32:57 EDT
An advisory has been issued which should help the problem
described in this bug report. This report is therefore being
closed with a resolution of ERRATA. For more information
on therefore solution and/or where to find the updated files,
please follow the link below. You may reopen this bug report
if the solution does not work for you.

http://rhn.redhat.com/errata/RHBA-2008-0672.html

Note You need to log in before you can comment on or make changes to this bug.