Bug 1746428 - Thunar causes delay in Xfce startup
Summary: Thunar causes delay in Xfce startup
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: Thunar
Version: 30
Hardware: Unspecified
OS: Unspecified
unspecified
medium
Target Milestone: ---
Assignee: Kevin Fenzi
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2019-08-28 12:56 UTC by Chris Tao
Modified: 2019-09-14 16:31 UTC (History)
3 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2019-09-06 10:57:49 UTC
Type: Bug


Attachments (Terms of Use)

Description Chris Tao 2019-08-28 12:56:53 UTC
Description of problem:
When I start Xfce on a fully-updated F30 system, xfdesktop and tray icons take abnormally long time (~10sec) to show up. tested Fedora-Xfce-Live-x86_64-31-20190826.n.0.iso too. Tried startx, lightdm, gdm and running xfce4-session directly but didn't make a difference.

Xfce 4.14 on Arch Linux & openSUSE Tumbleweed does not exhibit this behavior. The desktop loads almost instantly.

Strangely, if I start any application (that connects to the session manager) from the panel during the delay, desktop and tray icons show up immediately.

Comparing with Arch & openSUSE, I noticed Thunar is not registered with the session manager in Fedora, as can be seen in Settings->Session and startup->Current Session. 

I rebuilt Thunar src rpm locally and installed it, the delay is gone, and Thunar is now correctly shown in the "Current Session" dialog. It's unclear to me why a rebuild solved this.

Version-Release number of selected component (if applicable):
Thunar-1.8.9-1.fc30.x86_64
xfce4-session-4.14.0-1.fc30.x86_64


How reproducible:
Always


Additional info:
The issue is not present if I downgrade xfce4-session to 4.13.1, so I bisected xfce4-session to this commit: https://github.com/xfce-mirror/xfce4-session/commit/0a915310582803296fbfb075e1ea1c045b20bfcc
That might explain the delay when Thunar is not seen by the session manager.

Comment 1 Chris Tao 2019-08-28 13:50:54 UTC
I forgot to mention that I was not doing a mock build. Mock-built Thunar still has the same bug. A plain "rpmbuild --rebuild" works.

Turns out libSM-devel is missing in the build chroot.

Comment 2 Chris Tao 2019-08-28 14:10:33 UTC
I can confirm adding pkgconfig(sm) to BR indeed solves the problem. 

So Thunar in Fedora has always been missing sm support, but before the aforementioned commit in xfce4-session, clients were started async so it didn't block startup.

Comment 3 Mukundan Ragavan 2019-08-28 21:09:01 UTC
Nice work on the troubleshooting. Thanks!

I will rebuild Thunar with libsm enabled and push an update.

Comment 4 Fedora Update System 2019-08-28 21:25:01 UTC
FEDORA-2019-59adbff682 has been submitted as an update to Fedora 30. https://bodhi.fedoraproject.org/updates/FEDORA-2019-59adbff682

Comment 5 Fedora Update System 2019-08-28 21:25:01 UTC
FEDORA-2019-4da82e07b3 has been submitted as an update to Fedora 31. https://bodhi.fedoraproject.org/updates/FEDORA-2019-4da82e07b3

Comment 6 Fedora Update System 2019-08-30 00:04:45 UTC
Thunar-1.8.9-2.fc30 has been pushed to the Fedora 30 testing repository. If problems still persist, please make note of it in this bug report.
See https://fedoraproject.org/wiki/QA:Updates_Testing for
instructions on how to install test updates.
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2019-59adbff682

Comment 7 Fedora Update System 2019-08-30 12:17:13 UTC
Thunar-1.8.9-2.fc31 has been pushed to the Fedora 31 testing repository. If problems still persist, please make note of it in this bug report.
See https://fedoraproject.org/wiki/QA:Updates_Testing for
instructions on how to install test updates.
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2019-4da82e07b3

Comment 8 Fedora Update System 2019-09-05 11:48:08 UTC
Thunar-1.8.9-2.fc30 has been pushed to the Fedora 30 stable repository. If problems still persist, please make note of it in this bug report.

Comment 9 Fedora Update System 2019-09-14 00:06:58 UTC
Thunar-1.8.9-2.fc31 has been pushed to the Fedora 31 stable repository. If problems still persist, please make note of it in this bug report.

Comment 10 Fedora Update System 2019-09-14 16:31:07 UTC
Thunar-1.8.9-2.fc31 has been pushed to the Fedora 31 stable repository. If problems still persist, please make note of it in this bug report.


Note You need to log in before you can comment on or make changes to this bug.