Bug 1746434 - undefined method `create_virtual_machine' for #<Fog::Kubevirt::Utils::ExceptionWrapper:0x00007f35165ea3b0>
Summary: undefined method `create_virtual_machine' for #<Fog::Kubevirt::Utils::Excepti...
Keywords:
Status: CLOSED WORKSFORME
Alias: None
Product: Red Hat Satellite
Classification: Red Hat
Component: Compute Resources - CNV
Version: 6.6.0
Hardware: Unspecified
OS: Unspecified
unspecified
high vote
Target Milestone: 6.6.0
Assignee: Shira Maximov
QA Contact: Lukáš Hellebrandt
URL:
Whiteboard:
Depends On:
Blocks: 1687341 1695645 1696086
TreeView+ depends on / blocked
 
Reported: 2019-08-28 13:10 UTC by Lukáš Hellebrandt
Modified: 2019-09-09 09:04 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2019-09-09 09:04:28 UTC
Target Upstream Version:


Attachments (Terms of Use)
foreman-tail (17.54 KB, text/plain)
2019-08-28 13:12 UTC, Lukáš Hellebrandt
no flags Details

Description Lukáš Hellebrandt 2019-08-28 13:10:07 UTC
Description of problem:
When creating a new host in Kubevirt CR, the operation fails with error and traceback. Happens for both network based and image based provisioning.

The error in WebUI is:
"""
Unable to save
Failed to create a compute kubevirt4 (KubeVirt) instance tommy-grosser.lab.eng.rdu2.redhat.com: undefined method `create_virtual_machine' for #<Fog::Kubevirt::Utils::ExceptionWrapper:0x00007f35165ea3b0> 
"""

Traceback attached.

Version-Release number of selected component (if applicable):
Sat 6.6 snap 17, kubevirt 4.2. Regression from some previous snap.

How reproducible:
Deterministic

Steps to Reproduce:
1. Have a Satellite, have a Kubevirt instance added as a CR in the Satellite, have other necessary entities such as domain, subnet...
2. Hosts -> Create host
3. Deploy on Kubevirt, fill necessary fields
4. Submit

Actual results:
Error, traceback, no VM created

Expected results:
VM created successfully, no error, no traceback

Additional info:

Comment 3 Lukáš Hellebrandt 2019-08-28 13:12:11 UTC
Created attachment 1609003 [details]
foreman-tail

Comment 4 Shira Maximov 2019-09-09 09:04:28 UTC
I'm closing the BZ since This Bug is Kubevirt API bug,
this is the fix for the bug: https://github.com/kubernetes/kubernetes/pull/79495 
and it should be available in the lastest kubevirt version (0.20.1)


Note You need to log in before you can comment on or make changes to this bug.