Bug 174646 - Radeons crash with dri enabled
Summary: Radeons crash with dri enabled
Status: CLOSED DUPLICATE of bug 182196
Alias: None
Product: Fedora
Classification: Fedora
Component: kernel   
(Show other bugs)
Version: rawhide
Hardware: All
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Dave Jones
QA Contact: Brian Brock
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2005-12-01 02:06 UTC by Sammy
Modified: 2015-01-04 22:23 UTC (History)
3 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-03-06 23:12:20 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Sammy 2005-12-01 02:06:14 UTC
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (compatible; Konqueror/3.5; Linux; X11; en_US) KHTML/3.5.0 (like Gecko)

Description of problem:
I have two different radeons (mobility M10 and 7000 VE) that freeze the system 
if dri is enabled, requiring a reboot. I am at the daily rawhide level except the 
kernel is 2.6.14-1.1637_FC5. Here is the log right before the freeze: 
 
================================================= 
 
Nov 30 19:41:13 localhost kernel: [drm] Loading R300 Microcode 
Nov 30 19:41:13 localhost kernel: irq 11: nobody cared (try booting with the "irqpoll" 
option) 
Nov 30 19:41:13 localhost kernel:  [<c014a594>] __report_bad_irq+0x24/0x90 
Nov 30 19:41:13 localhost kernel:  [<c014a6a2>] note_interrupt+0x72/0xc0 
Nov 30 19:41:13 localhost kernel:  [<c0149fb9>] __do_IRQ+0xd9/0xf0 
Nov 30 19:41:13 localhost kernel:  [<c0104896>] do_IRQ+0x36/0x70 
Nov 30 19:41:13 localhost kernel:  [<c0103322>] common_interrupt+0x1a/0x20 
Nov 30 19:41:13 localhost kernel:  [<c01204de>] __do_softirq+0x2e/0xa0 
Nov 30 19:41:13 localhost kernel:  [<c0120577>] do_softirq+0x27/0x30 
Nov 30 19:41:13 localhost kernel:  [<c010489b>] do_IRQ+0x3b/0x70 
Nov 30 19:41:13 localhost kernel:  [<c0103322>] common_interrupt+0x1a/0x20 
Nov 30 19:41:13 localhost kernel:  [<c01e007b>] cond_read_bool+0xb/0x100 
Nov 30 19:41:13 localhost kernel:  [<f9bdb902>] 
radeon_driver_irq_preinstall+0x22/0x30 [radeon] 
Nov 30 19:41:14 localhost kernel:  [<f9bc21d3>] drm_irq_install+0x133/0x210 [drm] 
Nov 30 19:41:14 localhost kernel:  [<f9bc23db>] drm_control+0x7b/0xa0 [drm] 
Nov 30 19:41:14 localhost kernel:  [<f9bc2360>] drm_control+0x0/0xa0 [drm] 
Nov 30 19:41:14 localhost kernel:  [<f9bc0a33>] drm_ioctl+0xa3/0x1fd [drm] 
Nov 30 19:41:15 localhost kernel:  [<c015c611>] __handle_mm_fault+0x1e1/0x1f0 
Nov 30 19:41:15 localhost kernel:  [<f9bc0990>] drm_ioctl+0x0/0x1fd [drm] 
Nov 30 19:41:15 localhost kernel:  [<c017e849>] do_ioctl+0x69/0x70 
Nov 30 19:41:15 localhost kernel:  [<c017e98c>] vfs_ioctl+0x5c/0x1e0 
Nov 30 19:41:15 localhost kernel:  [<c017eb82>] sys_ioctl+0x72/0x90 
Nov 30 19:41:15 localhost kernel:  [<c01030fb>] sysenter_past_esp+0x54/0x75 
Nov 30 19:41:15 localhost kernel: handlers: 
Nov 30 19:41:15 localhost kernel: [<c02bbdf0>] (yenta_interrupt+0x0/0xc0) 
========================================================= 

Version-Release number of selected component (if applicable):
libdrm-1.0.5-2

How reproducible:
Always

Steps to Reproduce:
1. Try to start X on a radeon system with dri enabled 
2. 
3. 
   

Additional info:

Comment 1 Mike A. Harris 2005-12-21 11:31:07 UTC
Upgrade to the latest rawhide rpm packages of everything, in particular the
kernel, all X drivers, server, and libraries, etc.

We do not ship the r300 DRI driver, so it's odd that the R300 microcode is
being loaded.  Either way though, the above error is a kernel, rather than
X error.  Please attach your X server log file and config file to the
report for completeness.  (In general, they should be attached to all
X bug reports).

TIA

Comment 2 Mike A. Harris 2006-01-20 12:54:02 UTC
libdrm is the userland library, rather than the DRM kernel modules..

Reassigning to the kernel...

Comment 3 Dave Jones 2006-01-22 07:37:24 UTC
whats the newest rawhide kernel you've tried?

Comment 4 Orion Poplawski 2006-02-15 23:13:42 UTC
I think I'm seeing the same, though irq messages.  Last messages I see are:

Feb 15 16:09:35 vault kernel: [drm] Initialized drm 1.0.1 20051102
Feb 15 16:09:35 vault kernel: ACPI: PCI Interrupt 0000:01:05.0[A] -> GSI 16
(level, low) -> IRQ 185
Feb 15 16:09:35 vault kernel: [drm] Initialized radeon 1.21.0 20051229 on minor 0
Feb 15 16:09:35 vault kernel: agpgart: Found an AGP 2.0 compliant device at
0000:00:00.0.
Feb 15 16:09:35 vault kernel: agpgart: Putting AGP V2 device at 0000:00:00.0
into 1x mode
Feb 15 16:09:35 vault kernel: agpgart: Putting AGP V2 device at 0000:01:05.0
into 1x mode

Adapter is:

01:05.0 VGA compatible controller: ATI Technologies Inc Radeon RV100 QY [Radeon
7000/VE]

kernel is 2.6.15-1.1948_FC5smp

Commenting out Load "dri" prevents the hang.

This is a dual athlon mp system.


Comment 5 Dave Jones 2006-03-06 23:12:20 UTC

*** This bug has been marked as a duplicate of 182196 ***


Note You need to log in before you can comment on or make changes to this bug.