Bug 1746671 - Web console should NOT be blank when installing operators even if something wrong in this operator
Summary: Web console should NOT be blank when installing operators even if something w...
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: OpenShift Container Platform
Classification: Red Hat
Component: Management Console
Version: 4.2.0
Hardware: Unspecified
OS: Unspecified
high
high
Target Milestone: ---
: 4.2.0
Assignee: Samuel Padgett
QA Contact: Jian Zhang
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2019-08-29 05:26 UTC by Jian Zhang
Modified: 2019-10-16 06:40 UTC (History)
7 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2019-10-16 06:38:14 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Private Priority Status Summary Last Updated
Github openshift console pull 2534 0 None closed Bug 1746671: Avoid runtime error when OperatorHub install mode undefined 2020-11-06 12:39:31 UTC
Red Hat Product Errata RHBA-2019:2922 0 None None None 2019-10-16 06:40:24 UTC

Description Jian Zhang 2019-08-29 05:26:33 UTC
Description of problem:
The Web console status in the blank when installing Presto operator.
Screenshot: https://user-images.githubusercontent.com/15416633/63906659-3c079a80-ca4b-11e9-9314-2de40dc25bd9.png

Version-Release number of selected component (if applicable):
Cluster version is 4.2.0-0.nightly-2019-08-28-035628
mac:~ jianzhang$ oc exec catalog-operator-9d8bc57c-5v67r -- olm --version
OLM version: 0.11.0
git commit: 2959328fba0d1909ff9f24b365c2d8acbd3a19da

console version:
           io.openshift.build.commit.url=https://github.com/openshift/console/commit/3f5ddd2f12abb1a2a515d451da106fc45385f360

How reproducible:
always

Steps to Reproduce:
1. Install OCP 4.2
2. Login the Web console as the cluster-admin user, click "Operators" > "OperatorHub"-> "Big Data" -> "Presto Operator" -> "Install"


Actual results:
The page jumps in the blank status, and cannot recover after clicking the back button. But, you can just go back via URL redirection.
https://user-images.githubusercontent.com/15416633/63906659-3c079a80-ca4b-11e9-9314-2de40dc25bd9.png

Expected results:
I know something wrong in the operator, but we should pop-up errors instead of the blank page.

Additional info:

Comment 1 Samuel Padgett 2019-08-29 12:40:55 UTC
operator-hub-subscribe.tsx:64 Uncaught TypeError: Cannot read property 'supported' of undefined
    at OperatorHubSubscribeForm (operator-hub-subscribe.tsx:64)
    at renderWithHooks (react-dom.development.js:12938)
    at mountIndeterminateComponent (react-dom.development.js:15020)
    at beginWork (react-dom.development.js:15625)
    at performUnitOfWork (react-dom.development.js:19312)
    at workLoop (react-dom.development.js:19352)
    at HTMLUnknownElement.callCallback (react-dom.development.js:149)
    at Object.invokeGuardedCallbackDev (react-dom.development.js:199)
    at invokeGuardedCallback (react-dom.development.js:256)
    at replayUnitOfWork (react-dom.development.js:18578)

Comment 5 Yadan Pei 2019-09-04 01:15:07 UTC
Login the Web console as the cluster-admin user, click "Operators" > "OperatorHub"-> "Big Data" -> "Presto Operator" -> "Install"

Presto Operator can be successfully installed

Verified on 4.2.0-0.nightly-2019-09-02-172410

Comment 6 errata-xmlrpc 2019-10-16 06:38:14 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2019:2922


Note You need to log in before you can comment on or make changes to this bug.