Bug 174685 - RFE: weighting for available build servers
RFE: weighting for available build servers
Status: CLOSED NEXTRELEASE
Product: Fedora
Classification: Fedora
Component: plague (Show other bugs)
rawhide
All Linux
medium Severity medium
: ---
: ---
Assigned To: Dan Williams
Fedora Extras Quality Assurance
: FutureFeature
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2005-12-01 08:38 EST by Ville Skyttä
Modified: 2007-11-30 17:11 EST (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Enhancement
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-03-20 07:38:43 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Ville Skyttä 2005-12-01 08:38:19 EST
Submitted noarch jobs seem to be built on the ppc build server, which is the
slowest of them and a potential bottleneck.  It'd be better to have them built
on hammer{1,2,3}
Comment 1 Seth Vidal 2005-12-01 10:12:36 EST
adding dan.

Comment 2 Dan Williams 2005-12-01 10:22:02 EST
They will build on the first available builder, which happens to be ppc1 right
now .  There's no ordering to the builder list or preference weights for
builders yet.

While that's simple to add, would depsolving help out here?  If the rush to get
a job done is so you can start another job that depends on the first one, I
think depsolving would fix this since you could just queue both jobs and walk away.
Comment 3 Ville Skyttä 2005-12-01 13:06:12 EST
Yeah, depsolving helps in some cases.  This is not that urgent at the moment,
changing to RFE for future "rush hours"; for example it could be beneficial to
have this implemented a bit before FC5 time when there's prolly going to be a
lot more builds going on than right now.
Comment 4 Dan Williams 2006-03-20 07:38:43 EST
Should be in CVS HEAD, won't make it to STABLE_4 since it requires a config file
format change.

Note You need to log in before you can comment on or make changes to this bug.