Bug 174722 - Install of package fails due to scriptlet failure
Install of package fails due to scriptlet failure
Status: CLOSED CURRENTRELEASE
Product: Fedora
Classification: Fedora
Component: selinux-policy-targeted (Show other bugs)
rawhide
All Linux
medium Severity medium
: ---
: ---
Assigned To: Daniel Walsh
:
Depends On:
Blocks: 174428
  Show dependency treegraph
 
Reported: 2005-12-01 12:48 EST by Chris Lumens
Modified: 2007-11-30 17:11 EST (History)
0 users

See Also:
Fixed In Version: 2.0.7-1
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-03-20 20:45:31 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Chris Lumens 2005-12-01 12:48:30 EST
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.8) Gecko/20051103 Fedora/1.5-0.5.0.rc1 Firefox/1.5

Description of problem:
Installing selinux-policy-targeted from anaconda due to a preinstall scriptlet failure.  The first step in the pre scriptlet is to source /etc/selinux/config, which fails because this file is created by either the postinstall scriptlet or by anaconda after package installation has occurred.

The following lines are seen in /root/install.log after installation is complete:

/var/tmp/rpm-tmp.36853: line 2: /etc/selinux/config: No such file or directory.
error: %pre(selinux-policy-targeted-2.0.6-2.noarch) scriptlet failed, exit status 1
error: install %pre scriptlet failed (2), skipping selinux-policy-targeted-2.0.6-2.

The fix is to protect the source with a test for if the file exists.

Version-Release number of selected component (if applicable):
2.0.6-2

How reproducible:
Always

Steps to Reproduce:
1.  Do a fresh install.
2.  Examine /root/install.log.
3.  See that there are failures and also that the package has not been installed.

Additional info:
Comment 1 Daniel Walsh 2005-12-01 13:14:07 EST
Fixed in  selinux-policy-*-2.0.7-1

Note You need to log in before you can comment on or make changes to this bug.