Bugzilla (bugzilla.redhat.com) will be under maintenance for infrastructure upgrades and will not be available on July 31st between 12:30 AM - 05:30 AM UTC. We appreciate your understanding and patience. You can follow status.redhat.com for details.
Bug 1747260 - openshift-apiserver-operator: "Deleted target configmap openshift-apiserver/trusted-ca-bundle because source config does not exist" log msg every 3s
Summary: openshift-apiserver-operator: "Deleted target configmap openshift-apiserver/t...
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: OpenShift Container Platform
Classification: Red Hat
Component: openshift-apiserver
Version: 4.2.0
Hardware: Unspecified
OS: Unspecified
urgent
urgent
Target Milestone: ---
: 4.2.0
Assignee: Standa Laznicka
QA Contact: Xingxing Xia
URL:
Whiteboard:
: 1747509 1749567 (view as bug list)
Depends On:
Blocks: 1745493
TreeView+ depends on / blocked
 
Reported: 2019-08-30 01:31 UTC by Seth Jennings
Modified: 2019-10-16 06:39 UTC (History)
5 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2019-10-16 06:38:50 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Private Priority Status Summary Last Updated
Github openshift cluster-openshift-apiserver-operator pull 231 0 None closed Bug 1747260: Fix trusted-ca-bundle CM syncing 2020-10-30 15:48:08 UTC
Github openshift cluster-openshift-apiserver-operator pull 232 0 None closed Bug 1747260: Last (?) fix to trusted-ca CM syncing 2020-10-30 15:47:52 UTC
Red Hat Product Errata RHBA-2019:2922 0 None None None 2019-10-16 06:39:04 UTC

Description Seth Jennings 2019-08-30 01:31:13 UTC
openshift-apiserver-operator is printing the $subject msg every 3s

$ ogcv
NAME      VERSION                        AVAILABLE   PROGRESSING   SINCE   STATUS
version   4.2.0-0.ci-2019-08-29-200631   True        False         122m    Cluster version is 4.2.0-0.ci-2019-08-29-200631


I0830 01:27:41.786006       1 event.go:209] Event(v1.ObjectReference{Kind:"Deployment", Namespace:"openshift-apiserver-operator", Name:"openshift-apiserver-operator", UID:"bb027c01-caae-11e9-864e-fa163e772a61", APIVersion:"apps/v1", ResourceVersion:"", FieldPath:""}): type: 'Normal' reason: 'TargetConfigDeleted' Deleted target configmap openshift-apiserver/trusted-ca-bundle because source config does not exist
I0830 01:27:44.572424       1 event.go:209] Event(v1.ObjectReference{Kind:"Deployment", Namespace:"openshift-apiserver-operator", Name:"openshift-apiserver-operator", UID:"bb027c01-caae-11e9-864e-fa163e772a61", APIVersion:"apps/v1", ResourceVersion:"", FieldPath:""}): type: 'Normal' reason: 'TargetConfigDeleted' Deleted target configmap openshift-apiserver/trusted-ca-bundle because source config does not exist
I0830 01:27:47.573810       1 event.go:209] Event(v1.ObjectReference{Kind:"Deployment", Namespace:"openshift-apiserver-operator", Name:"openshift-apiserver-operator", UID:"bb027c01-caae-11e9-864e-fa163e772a61", APIVersion:"apps/v1", ResourceVersion:"", FieldPath:""}): type: 'Normal' reason: 'TargetConfigDeleted' Deleted target configmap openshift-apiserver/trusted-ca-bundle because source config does not exist
I0830 01:27:50.396889       1 event.go:209] Event(v1.ObjectReference{Kind:"Deployment", Namespace:"openshift-apiserver-operator", Name:"openshift-apiserver-operator", UID:"bb027c01-caae-11e9-864e-fa163e772a61", APIVersion:"apps/v1", ResourceVersion:"", FieldPath:""}): type: 'Normal' reason: 'TargetConfigDeleted' Deleted target configmap openshift-apiserver/trusted-ca-bundle because source config does not exist
I0830 01:27:53.174089       1 event.go:209] Event(v1.ObjectReference{Kind:"Deployment", Namespace:"openshift-apiserver-operator", Name:"openshift-apiserver-operator", UID:"bb027c01-caae-11e9-864e-fa163e772a61", APIVersion:"apps/v1", ResourceVersion:"", FieldPath:""}): type: 'Normal' reason: 'TargetConfigDeleted' Deleted target configmap openshift-apiserver/trusted-ca-bundle because source config does not exist

Possibly related:
https://github.com/openshift/cluster-openshift-apiserver-operator/pull/228

Comment 1 Michal Fojtik 2019-08-30 13:56:15 UTC
Setting urgent as this means we don't wire trusted-ca config map properly in operand.

Comment 2 Greg Blomquist 2019-09-04 14:08:31 UTC
*** Bug 1747509 has been marked as a duplicate of this bug. ***

Comment 3 Adam Kaplan 2019-09-05 17:54:06 UTC
Blocks #1745493 (imagestream import fails because proxy isn't trusted)

Comment 4 Standa Laznicka 2019-09-06 08:05:10 UTC
*** Bug 1749567 has been marked as a duplicate of this bug. ***

Comment 6 Xingxing Xia 2019-09-10 01:09:45 UTC
Verified in 4.2.0-0.nightly-2019-09-08-180038 . No such log msg in oaso pod. Proxy CA is mounted well in oas pods. The trusted-ca-bundle cm in oas project is copied from oaso project with the inject label removed.

Comment 7 errata-xmlrpc 2019-10-16 06:38:50 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2019:2922


Note You need to log in before you can comment on or make changes to this bug.