Bug 174731 - gcc -m32 does not work under mock
Summary: gcc -m32 does not work under mock
Status: CLOSED NOTABUG
Alias: None
Product: Fedora
Classification: Fedora
Component: mock   
(Show other bugs)
Version: 4
Hardware: x86_64
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Seth Vidal
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2005-12-01 19:20 UTC by Thomas Sailer
Modified: 2007-11-30 22:11 UTC (History)
2 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-12-01 19:22:32 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Thomas Sailer 2005-12-01 19:20:57 UTC
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (compatible; Konqueror/3.4; Linux) KHTML/3.4.2 (like Gecko)

Description of problem:
Trying to build any nontrivial program inside mock on x86_64 with -m32 results 
in the following failure: 
 
+ gcc -o -Wall -g -m32 -o hello_32 hello.c 
In file included from /usr/include/features.h:342, 
                 from /usr/include/stdio.h:28, 
                 from hello.c:1: 
/usr/include/gnu/stubs.h:7:27: error: gnu/stubs-32.h: No such file or 
directory 
 
This is because mock only installs glibc-devel.x86_64, 
but /usr/include/gnu/stubs-32.h is included in glibc-devel.i386, so really, 
one has to install both glibc-devel.x86_64 and glibc-devel.i386. 
 

Version-Release number of selected component (if applicable):
mock-0.4-2.fc4

How reproducible:
Always

Steps to Reproduce:
mock hello-1.0-1.src.rpm 
 

Additional info:

Comment 1 Seth Vidal 2005-12-01 19:22:32 UTC
mock doesn't install those b/c in the default configs any non-x86_64/noarch
packages  are excluded from use.

Go edit your mock config file to allow those in.



Comment 2 Thomas Sailer 2005-12-01 19:27:17 UTC
yeah great. Now tell me how to do this on the fedora extras build machines. I 
don't think I have this much control over the config files there. 

Comment 3 Seth Vidal 2005-12-01 19:30:30 UTC
Ah, you didn't say that before.

So why are you trying to build against i386 includes on x86_64?


Comment 4 Thomas Sailer 2005-12-01 19:46:45 UTC
I'm trying to build ghdl. ghdl is basically a GCC frontend, and gcc likes to 
build crtbegin/crtend etc. with differnet compiler flags. 


Note You need to log in before you can comment on or make changes to this bug.