Bugzilla (bugzilla.redhat.com) will be under maintenance for infrastructure upgrades and will not be available on July 31st between 12:30 AM - 05:30 AM UTC. We appreciate your understanding and patience. You can follow status.redhat.com for details.
Bug 1747366 - [proxy] Error while validating cloud credentials in proxy-enabled upi/aws install
Summary: [proxy] Error while validating cloud credentials in proxy-enabled upi/aws ins...
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: OpenShift Container Platform
Classification: Red Hat
Component: Cloud Credential Operator
Version: 4.2.0
Hardware: Unspecified
OS: Unspecified
high
high
Target Milestone: ---
: 4.2.0
Assignee: Joel Diaz
QA Contact: Gaoyun Pei
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2019-08-30 08:27 UTC by Gaoyun Pei
Modified: 2019-10-18 13:51 UTC (History)
3 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2019-10-16 06:39:13 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Private Priority Status Summary Last Updated
Github openshift cloud-credential-operator pull 111 0 'None' closed Bug 1747366: Allow use of global proxy 2020-11-23 04:04:11 UTC
Red Hat Product Errata RHBA-2019:2922 0 None None None 2019-10-16 06:39:23 UTC

Comment 2 Devan Goodwin 2019-09-06 15:23:47 UTC
We'd been told we should always assume cloud APIs are reachable, but this does not seem to be working out, we're investigating adding proxy support, Joel Diaz is looking into this.

Comment 3 Stephen Cuppett 2019-09-09 14:05:35 UTC
*** Bug 1743483 has been marked as a duplicate of this bug. ***

Comment 4 Devan Goodwin 2019-09-09 14:28:08 UTC
Joel is working on this as we speak. We're going to do an initial phase hopefully today or tomorrow to allow proxy support. This initial step will not support *changing* the proxy env vars, you would need to manually delete the cred operator pods to do so.

Phase 2 will come hopefully by end of week, but there is some risk here, and will allow the cred minter to support changing the proxy vars.

Comment 7 Johnny Liu 2019-09-16 01:13:15 UTC
Verified this bug with 4.2.0-0.nightly-2019-09-12-114308 (privatelink + proxy), and PASS.

Comment 8 errata-xmlrpc 2019-10-16 06:39:13 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2019:2922


Note You need to log in before you can comment on or make changes to this bug.