Bug 174738 - What happened to X11 dev docs
What happened to X11 dev docs
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: xorg-x11 (Show other bugs)
rawhide
All Linux
medium Severity medium
: ---
: ---
Assigned To: Mike A. Harris
David Lawrence
: Reopened
: 176757 (view as bug list)
Depends On: 199925 199927
Blocks: FC6Target
  Show dependency treegraph
 
Reported: 2005-12-01 15:27 EST by Jonathan Kamens
Modified: 2007-11-30 17:11 EST (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-07-24 22:02:34 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Jonathan Kamens 2005-12-01 15:27:17 EST
The X11 dev docs, e.g., the roff Xaw and Xt manuals, seem to have 
disappeared.  Am I just missing the RPM they're packaged in, or are they 
really gone?  Any chance of getting them back?
Comment 1 Mike A. Harris 2005-12-01 22:38:33 EST
X.Org has not yet provided the documentation in modular X, so there are no
packages yet.  Once X.Org provides documentation tarballs that build, we
will probably add them to Fedora however.
Comment 2 Mike A. Harris 2006-01-31 19:50:57 EST
*** Bug 176757 has been marked as a duplicate of this bug. ***
Comment 3 Mike A. Harris 2006-01-31 20:40:48 EST
X11R7 has provided the documentation tarballs, now all we need to do is build
packages for rawhide.  Adding to FC5Blocker tracker.
Comment 4 Mike A. Harris 2006-02-08 15:25:29 EST
Package inclusion approvals:

Technical lead (notting):  approved
    <mharris> I've got quite a bit of stuff to do, and 2 things were making a
              couple other new packages (X documentation and the utils that
              build it)
    <mharris> https://bugzilla.redhat.com/bugzilla/show_bug.cgi?id=174738
    <notting> 174738 seems fine


Installer team (jeremy):  rejected
    (Discussion with jeremy to find out wether this affected the installer
     did not yield any problems it would cause for the installer, however
     it was rejected due to the upstream documentation being a monolithic
     tarball instead of being individual documentation in each package
     which it is documenting (Xaw/Xt/proto headers etc.)


Release engineering (jkeating):  awaiting approvals of notting/jeremy


Status for FC5:  X documentation rejected for FC5 by installer team due
to unsatisfactory upstream tarball packaging (although it isn't clear
how this affects the installer).

Comment 5 Mike A. Harris 2006-07-24 08:39:11 EDT
Packages submitted for Fedora Core review:

Bug #199925
Bug #199927

Once they have been approved, the packages will be checked into CVS and
built for rawhide.  For those looking to download them via FTP, please
note that the new packages are 'noarch' now as they are in separate
packaging.
Comment 6 Mike A. Harris 2006-07-24 22:02:34 EDT
The packages have now been approved and built in rawhide as 'noarch'.

Note You need to log in before you can comment on or make changes to this bug.