Bug 1747382 - /etc/sysconfig/kernel references new-kernel-pkg which does not exist
Summary: /etc/sysconfig/kernel references new-kernel-pkg which does not exist
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Enterprise Linux 8
Classification: Red Hat
Component: anaconda
Version: 8.1
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: rc
: 8.0
Assignee: Javier Martinez Canillas
QA Contact: Release Test Team
Sharon Moroney
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2019-08-30 09:25 UTC by Jan Pazdziora
Modified: 2020-04-28 15:31 UTC (History)
8 users (show)

Fixed In Version: anaconda-29.19.2.4-1
Doc Type: Bug Fix
Doc Text:
.The `/etc/sysconfig/kernel` file no longer references the `new-kernel-pkg` script Previously, the `/etc/sysconfig/kernel` file referenced the `new-kernel-pkg` script. However, the `new-kernel-pkg` script is not included in a RHEL 8 system. With this update, the reference to the `new-kernel-pkg` script has been removed from the `/etc/sysconfig/kernel` file.
Clone Of:
Environment:
Last Closed: 2020-04-28 15:30:46 UTC
Type: Bug
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2020:1584 None None None 2020-04-28 15:31:18 UTC

Description Jan Pazdziora 2019-08-30 09:25:58 UTC
Description of problem:

The default /etc/sysconfig/kernel on RHEL 8 says:

# UPDATEDEFAULT specifies if new-kernel-pkg should make
# new kernels the default
UPDATEDEFAULT=yes

However, there is no new-kernel-pkg in RHEL 8.

Version-Release number of selected component (if applicable):

anaconda-core-29.19.1.10-1.el8.x86_64

How reproducible:

Deterministic.

Steps to Reproduce:
1. Try to figure out what mechanism updates the bootloader upon kernel update.
2. Get to /etc/sysconfig/kernel and read the comment.

Actual results:

Get stuck looking for new-kernel-pkg.

Expected results:

Get comment which points the admin to the up-to-date mechanism which processes that UPDATEDEFAULT.

Additional info:

Comment 1 Jiri Konecny 2019-09-02 11:35:36 UTC
Could bootloader devs please look on this issue and tell us their opinion?

Comment 2 Javier Martinez Canillas 2019-09-02 12:46:14 UTC
I've created pull-request upstream against the rhel-8 branch:

https://github.com/rhinstaller/anaconda/pull/2110

Comment 10 Zdenek Veleba 2020-02-04 07:42:52 UTC
Verified in RHEL-8.2.0-20191219.0, anaconda 29.19.2.6

Comment 13 errata-xmlrpc 2020-04-28 15:30:46 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2020:1584


Note You need to log in before you can comment on or make changes to this bug.