Bugzilla (bugzilla.redhat.com) will be under maintenance for infrastructure upgrades and will not be available on July 31st between 12:30 AM - 05:30 AM UTC. We appreciate your understanding and patience. You can follow status.redhat.com for details.
Bug 1747432 - missing terminationMessagePolicy: FallbackToLogsOnError in MCO containers
Summary: missing terminationMessagePolicy: FallbackToLogsOnError in MCO containers
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: OpenShift Container Platform
Classification: Red Hat
Component: Machine Config Operator
Version: 4.2.0
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
: 4.2.0
Assignee: Antonio Murdaca
QA Contact: Micah Abbott
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2019-08-30 12:34 UTC by Antonio Murdaca
Modified: 2019-10-16 06:39 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2019-10-16 06:39:13 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Private Priority Status Summary Last Updated
Github openshift machine-config-operator pull 1093 0 None closed Bug 1747432: manifests: Add missing terminationMessagePolicy FallbackToLogsOnError 2020-08-31 14:58:52 UTC
Red Hat Product Errata RHBA-2019:2922 0 None None None 2019-10-16 06:39:23 UTC

Description Antonio Murdaca 2019-08-30 12:34:41 UTC
Description of problem:

not all the MCO containers are setting terminationMessagePolicy: FallbackToLogsOnError. That's required in 4.2 for Insight (see https://github.com/openshift/machine-config-operator/pull/1093#issue-312573618)


Version-Release number of selected component (if applicable):

4.2


How reproducible:

always


Steps to Reproduce:
1. just missing from oc describe <pod>
2.
3.

Actual results:

no terminationMessagePolicy: FallbackToLogsOnError

Expected results:

terminationMessagePolicy: FallbackToLogsOnError in MCO containers from pods

Additional info:

Comment 2 Michael Nguyen 2019-09-04 15:58:26 UTC
Verified on 4.2.0-0.ci-2019-09-04-105733

$ oc get -n openshift-machine-config-operator pods/machine-config-daemon-frmlm -o yaml | grep termination
    terminationMessagePath: /dev/termination-log
    terminationMessagePolicy: FallbackToLogsOnError
  terminationGracePeriodSeconds: 600
$ oc get -n openshift-machine-config-operator pods/machine-config-daemon-jfm78 -o yaml | grep termination
    terminationMessagePath: /dev/termination-log
    terminationMessagePolicy: FallbackToLogsOnError
  terminationGracePeriodSeconds: 600
$ oc get -n openshift-machine-config-operator pods/machine-config-daemon-p8p4m -o yaml | grep termination
    terminationMessagePath: /dev/termination-log
    terminationMessagePolicy: FallbackToLogsOnError
  terminationGracePeriodSeconds: 600
$ oc get -n openshift-machine-config-operator pods/machine-config-daemon-rzsqj -o yaml | grep termination
    terminationMessagePath: /dev/termination-log
    terminationMessagePolicy: FallbackToLogsOnError
  terminationGracePeriodSeconds: 600
$ oc get -n openshift-machine-config-operator pods/machine-config-daemon-vfvsd -o yaml | grep termination
    terminationMessagePath: /dev/termination-log
    terminationMessagePolicy: FallbackToLogsOnError
  terminationGracePeriodSeconds: 600
$ oc get -n openshift-machine-config-operator pods/machine-config-operator-669d578c9f-jx4gw -o yaml | grep termination
    terminationMessagePath: /dev/termination-log
    terminationMessagePolicy: FallbackToLogsOnError
  terminationGracePeriodSeconds: 30
$ oc get -n openshift-machine-config-operator pods/machine-config-server-c9qnh -o yaml | grep termination
    terminationMessagePath: /dev/termination-log
    terminationMessagePolicy: FallbackToLogsOnError
  terminationGracePeriodSeconds: 30
$ oc get -n openshift-machine-config-operator pods/machine-config-server-cgshd -o yaml | grep termination
    terminationMessagePath: /dev/termination-log
    terminationMessagePolicy: FallbackToLogsOnError
  terminationGracePeriodSeconds: 30
$ oc get -n openshift-machine-config-operator pods/machine-config-server-xh494 -o yaml | grep termination
    terminationMessagePath: /dev/termination-log
    terminationMessagePolicy: FallbackToLogsOnError
  terminationGracePeriodSeconds: 30
$ oc get -n openshift-machine-config-operator pods/machine-config-controller-75bfcbb74d-6jhc5 -o yaml | grep termination
    terminationMessagePath: /dev/termination-log
    terminationMessagePolicy: FallbackToLogsOnError
  terminationGracePeriodSeconds: 30

Comment 3 errata-xmlrpc 2019-10-16 06:39:13 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2019:2922


Note You need to log in before you can comment on or make changes to this bug.