Bugzilla (bugzilla.redhat.com) will be under maintenance for infrastructure upgrades and will not be available on July 31st between 12:30 AM - 05:30 AM UTC. We appreciate your understanding and patience. You can follow status.redhat.com for details.
Bug 1747434 - Plugin-based NavItems are not highlighted as active on page refresh
Summary: Plugin-based NavItems are not highlighted as active on page refresh
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: OpenShift Container Platform
Classification: Red Hat
Component: Console Kubevirt Plugin
Version: 4.2.0
Hardware: Unspecified
OS: Unspecified
unspecified
medium
Target Milestone: ---
: 4.2.0
Assignee: Tomas Jelinek
QA Contact: Nelly Credi
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2019-08-30 12:38 UTC by Jiri Tomasek
Modified: 2019-10-16 06:39 UTC (History)
4 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2019-10-16 06:39:13 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Private Priority Status Summary Last Updated
Github openshift console pull 2546 0 None None None 2019-08-30 12:42:54 UTC
Red Hat Product Errata RHBA-2019:2922 0 None None None 2019-10-16 06:39:23 UTC

Description Jiri Tomasek 2019-08-30 12:38:00 UTC
Description of problem:
NavItems provided by plugins are loaded after initial NavSections render.
NavSection does not update the active child when plugin-based NavItems are added.

Steps to Reproduce:
1. With kubevirt plugin enabled, go to 'Workloads -> Virtual Machines'
2. refresh the browser page

Actual results:

'Workloads' nav section is closed and Virtual Machines nav item is not highlighted


Expected results:

'Workloads' nav section is open and Virtual Machines nav item is highlighted

Comment 2 Guohua Ouyang 2019-09-06 06:17:26 UTC
verified on 4.2.0-0.nightly-2019-09-04-142146

Comment 3 errata-xmlrpc 2019-10-16 06:39:13 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2019:2922


Note You need to log in before you can comment on or make changes to this bug.