Bug 174748 - i2o raidutils don't work in latest kernels
i2o raidutils don't work in latest kernels
Product: Fedora
Classification: Fedora
Component: kernel (Show other bugs)
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Dave Jones
Brian Brock
Depends On:
  Show dependency treegraph
Reported: 2005-12-01 16:52 EST by Danny Yee
Modified: 2015-01-04 17:23 EST (History)
5 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Last Closed: 2005-12-15 20:14:26 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---

Attachments (Terms of Use)

  None (edit)
Description Danny Yee 2005-12-01 16:52:27 EST
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.7.12) Gecko/20050922 Fedora/1.0.7-1.1.fc3 Firefox/1.0.7

Description of problem:
I can't get the i2o raidutil utility to work on the latest Fedora Core
4 kernels.

I did a brand new install of FC4, and the i2o raidutils rpm from
http://i2o.shadowconnect.com/download.php worked fine (after I created

But when I rebooted with all the upgrades, I got the EngineConnect
failed compatibility error messages.

This is repeatable -- raidutil runs fine with kernel
2.6.11-1.1369_FC4smp but fails with 2.6.14-1.1644_FC4smp or 2.6.14-1.1644_FC4

I have another FC4 machine running 2.6.12-1.1456_FC4 on which raidutil
works, so it looks like the problem appeared after 1456.  I'll try to do some more tests with different kernel versions.

Version-Release number of selected component (if applicable):

How reproducible:

Steps to Reproduce:
1. install Fedora Core 4 (with kernel 2.6.11-1.1369), install raidutils-0.0.6-1.i386.rpm (and mknod /dev/i2o/ctl, etc)
2. /usr/bin/raidutil works fine
3. update to kernel 2.6.14-1.1644
4. raidutil doesn't work
5. reboot with either kernel to repeat


Actual Results:  osdIOrequest : File /dev/dpti17 Could Not Be OpenedEngine connect failed: COMPATIBILITY number

Additional info:
Comment 1 Danny Yee 2005-12-01 20:27:56 EST
I've done some more trials (on a different machine to the one I originally found
the problem on) and got the following results:

Doesn't work on:

Works on:

So it looks like something happened with 2.6.13.
Comment 2 Dave 2005-12-03 13:09:49 EST
I am also having the same problems. The card in this case is an Adaptec 2100S
and I am currently using the following kernel:


I will see if I can give this a test with FC5 test1 asap, at least that might
provide a path out of the current situation.
Comment 3 Markus Lidel 2005-12-04 15:53:01 EST

could you please verify that you have enabled ioctls like mentioned now in the FAQ:


Thank you very much.

Best regards,

Markus Lidel
Comment 4 Danny Yee 2005-12-04 19:16:37 EST
Yes, I'm running 
  # temporary hack until i2o modules do this automatically
  mknod /dev/i2o/ctl c 10 166
in /etc/rc.local

and I have a /usr/local/sbin/raidutil that does
  modprobe i2o_proc
  modprobe i2o_config
  /usr/bin/raidutil $*

And I can reliably demonstrate the problem by rebooting the same machine with
different kernels (see above for which ones).

I don't build my own kernels so I can't test the "enable ioctls" bit - but is it
possible that more recent FC 4 kernels have been built without it?

Comment 5 Markus Lidel 2005-12-05 05:17:01 EST

yep, it's most likely, because ioctl isn't enabled by default.

Best regards,

Markus Lidel
Comment 6 Danny Yee 2005-12-05 05:55:31 EST
Is there some way we can enable ioctls in FC 4 kernels more recent than
2.6.12-1.1456_FC4 (without recompiling a kernel)?  Barring that, could we have
it included in the next Fedora Core kernel update?

Features like that really shouldn't be turned off by upgrades -- it's
disconcerting having systems stop working without warning.
Comment 7 Markus Lidel 2005-12-05 14:29:01 EST

because it's only the i2o_config.ko module, you only have to compile this module
on a machine and load it... Nothing else is needed...

It's my fault, because the ioctls was not enabled by default when the config
option was added...

Best regards,

Markus Lidel
Comment 8 Danny Yee 2005-12-05 21:16:25 EST
Thanks, I'll have a go at rebuilding the i2o_config module.

Can we make sure this is fixed (ie, ioctls is enabled and raidutil works) in
both the next FC 4 kernel update and in FC 5?  (I haven't tried FC 5 at all, but
Dave said he was going to so I'll leave that to him.)
Comment 9 Dave Jones 2005-12-06 18:32:18 EST
I've reenabled the ioctls in CVS.  They'll be back on in the next kernel update.
Comment 10 Dave 2005-12-15 17:21:06 EST
While I can't confirm that FC5 works (I have it running, but not on a machine
with this controller), I can confirm that raidutils works with the latest FC4

Thanks to all involved.

[root@luggage ~]# uname -a
Linux luggage.darkglobe.int 2.6.14-1.1653_FC4 #1 Tue Dec 13 21:32:09 EST 2005
i686 athlon i386 GNU/Linux
[root@luggage ~]# mknod /dev/i2o/ctl c 10 166
[root@luggage ~]# modprobe i2o_config
[root@luggage ~]# raidutil -L all
RAIDUTIL  Version: 3.31  Date: 8/12/2002  LINUX CLI Configuration Utility
Adaptec ENGINE  Version: 3.31  Date: 8/12/2002  Adaptec LINUX SCSI Engine

#  b0 b1 b2  Controller     Cache  FW    NVRAM     Serial     Status
d0 --        ADAP2100S      16MB   370F  CHNL 1.1  BF0A337239XOptimal

Physical View
Address    Type              Manufacturer/Model         Capacity  Status
d0b0t0d0   Disk Drive (DASD) MAXTOR   ATLAS10K4_36WLS   35074MB   Optimal
d0b0t1d0   Disk Drive (DASD) MAXTOR   ATLAS10K4_36WLS   35074MB   Optimal
d0b0t2d0   Disk Drive (DASD) MAXTOR   ATLAS10K4_36WLS   35074MB   Optimal
d0b0t4d0   Disk Drive (DASD) MAXTOR   ATLAS10K4_36WLS   35074MB   Optimal


Note You need to log in before you can comment on or make changes to this bug.