This service will be undergoing maintenance at 00:00 UTC, 2017-10-23 It is expected to last about 30 minutes
Bug 174753 - greater than one snapshots do not sync and behave the same as the first snapshot
greater than one snapshots do not sync and behave the same as the first snapshot
Status: CLOSED NEXTRELEASE
Product: Red Hat Enterprise Linux 4
Classification: Red Hat
Component: lvm2 (Show other bugs)
4.3
All Linux
medium Severity medium
: ---
: ---
Assigned To: Jonathan Earl Brassow
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2005-12-01 17:07 EST by Corey Marthaler
Modified: 2007-11-30 17:07 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-01-23 12:00:13 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Corey Marthaler 2005-12-01 17:07:13 EST
Description of problem:
When I write files A B C to an origin fs, and then snap, those files show up in
the snap fs everytime without a sleep or a sync in between, however when I
create more files D E F to the origin, and then create a 2nd snap, those files
won't show up unless I do a sync before the 2nd snap or a sleep of >6 sec. In
ext2, even with the sleep of >6, the 2nd snap wont work without a manual sync
since it apparently doesn't have the same freeze hooks as ext3.

How reproducible:
everytime
Comment 1 Alasdair Kergon 2005-12-09 12:48:33 EST
Need to think about this: have seen similar problem for a long time when using
loopback.  Is some flushing missing from lvm2 or dm?
Comment 2 Jonathan Earl Brassow 2005-12-13 19:16:03 EST
haven't been able to reproduce this with kernel-2.6.9-24.EL

I was able to easily create it with earlier kernels
Comment 3 Jonathan Earl Brassow 2005-12-13 19:30:32 EST
can't reproduce with kernel-2.6.9-25.EL either...  please verify
Comment 4 Corey Marthaler 2006-01-18 17:53:42 EST
This appears to be fixed with the latest kern/rpms

[root@link-08 bin]# uname -ar
Linux link-08 2.6.9-28.ELsmp #1 SMP Fri Jan 13 17:08:22 EST 2006 x86_64 x86_64
x86_64 GNU/Linux
[root@link-08 bin]# rpm -q lvm2
lvm2-2.02.01-1.3.RHEL4
[root@link-08 bin]# rpm -q device-mapper
device-mapper-1.02.02-3.0.RHEL4
Comment 5 Alasdair Kergon 2006-01-19 12:47:04 EST
OK - not sure of the precise cause, but I'll close this.

Note You need to log in before you can comment on or make changes to this bug.