Bug 17476 - KiscStart: Encrypted password placed into wrong file
KiscStart: Encrypted password placed into wrong file
Status: CLOSED CURRENTRELEASE
Product: Red Hat Linux
Classification: Retired
Component: bootpc (Show other bugs)
6.2
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Erik Troan
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2000-09-13 15:28 EDT by Andrei Ivanov
Modified: 2008-05-01 11:37 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2002-07-15 12:37:47 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Andrei Ivanov 2000-09-13 15:28:28 EDT
KickStart'ed with the following in my ks.cfg file (ks=floppy):

  auth --useshadow
  rootpw --iscrypted AaAUb94kU3J3w

After successfull installation logged in ... without root's password.
This is what I've got in passwd/shadow:

  # grep ^root: /etc/passwd /etc/shadow
  /etc/passwd:root:AaAUb94kU3J3w:0:0:root:/root:/bin/bash
  /etc/shadow:root::11213:0:99999:7:::

As workaround used the following code in ks.cfg:

#----- cut here --------------------------
cp /etc/passwd /tmp/passwd
sed -e /^root:/s/root:[^:]*:/root:x:/ /tmp/passwd > /etc/passwd
cp /etc/shadow /tmp/shadow
sed -e "/^root:/s*root::*root:`grep '^root:' /tmp/passwd|cut -d: -f2`:*" \
       /tmp/shadow > /etc/shadow
rm -f /tmp/passwd /tmp/shadow
#----- cut here --------------------------
Comment 1 Brock Organ 2000-09-14 09:57:49 EDT
this is a known issue and was resolved via a new boot disk ... thanks for your
report!

please see http://www.redhat.com/support/errata/RHBA-2000010-01.html
for details ...
Comment 2 Andrei Ivanov 2000-09-14 13:35:27 EDT
I'm sorry, but you're wrong, guys, in your supposition that you've resolved this
bug :-( Just downloaded boot-20000407.img and copied it onto floppy disk.
Tried to kickstart computer with auth/rootpw as above twice - exactly the
same picture. Then tried this:

  auth --useshadow --enablemd5
  rootpw --iscrypted $1$F3mDOWtl$0hLycXBk.40arokEzLuG11

Exactly the same!!! Encrypted password stored in /etc/passwd, and 2nd entry
in /etc/shadow remains empty.
Comment 3 Erik Troan 2000-09-29 12:14:41 EDT
This wasn't fixed by the boot disk -- sorry for the misleading response. This is
still broken in 7.0 afaik. Brock, can you verify this is broken in 7.0?

Note You need to log in before you can comment on or make changes to this bug.