Bug 1747669 - python2-cryptography fails to install in Fedora rawhide
Summary: python2-cryptography fails to install in Fedora rawhide
Keywords:
Status: CLOSED NOTABUG
Alias: None
Product: Fedora
Classification: Fedora
Component: python-cryptography
Version: rawhide
Hardware: Unspecified
OS: Unspecified
unspecified
high
Target Milestone: ---
Assignee: Miro Hrončok
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On: 1739531
Blocks: F31FailsToInstall PY2FTBI
TreeView+ depends on / blocked
 
Reported: 2019-08-31 15:08 UTC by Miro Hrončok
Modified: 2019-09-02 10:18 UTC (History)
7 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2019-09-02 10:18:14 UTC
Type: Bug


Attachments (Terms of Use)

Description Miro Hrončok 2019-08-31 15:08:28 UTC
python2-cryptography-2.6.1-3.fc32.x86_64 fails to install in Fedora rawhide:

  nothing provides python2-ipaddress needed by python2-cryptography-2.6.1-3.fc32.x86_64
  nothing provides python2.7dist(ipaddress) needed by python2-cryptography-2.6.1-3.fc32.x86_64

This is most likely caused by a dependency that was retired.
Please drop the dependency, unretire the dependency or remove the package. Thanks

Comment 1 Miro Hrončok 2019-09-02 07:30:27 UTC
I cannot install bzr:

Error: 
 Problem: package bzr-2.7.0-23.fc30.x86_64 requires python2-paramiko, but none of the providers can be installed
  - package python2-paramiko-2.6.0-3.fc32.noarch requires python2-cryptography >= 2.5, but none of the providers can be installed
  - package python2-paramiko-2.6.0-3.fc32.noarch requires python2.7dist(cryptography) >= 2.5, but none of the providers can be installed
  - cannot install the best candidate for the job
  - nothing provides python2-ipaddress needed by python2-cryptography-2.6.1-3.fc32.x86_64
  - nothing provides python2.7dist(ipaddress) needed by python2-cryptography-2.6.1-3.fc32.x86_64

Comment 2 Christian Heimes 2019-09-02 07:47:28 UTC
The Python 2 variant of cryptography requires the ipaddress package in multiple places. I cannot remove the dependency. Please reinstate the python2-ipaddress package.

Comment 3 Miro Hrončok 2019-09-02 07:57:34 UTC
> Please reinstate the python2-ipaddress package.

Who, me? I guess I can do it and orphan it immediately.

Comment 4 Miro Hrončok 2019-09-02 08:00:05 UTC
https://pagure.io/releng/issue/8721


Note You need to log in before you can comment on or make changes to this bug.