Bug 174767 - Memory separation test can fail on 64bit platforms
Memory separation test can fail on 64bit platforms
Status: CLOSED ERRATA
Product: Red Hat Enterprise Linux 4
Classification: Red Hat
Component: amtu (Show other bugs)
4.0
All Linux
medium Severity medium
: ---
: ---
Assigned To: Steve Grubb
:
Depends On:
Blocks: 175213 RHEL4U4Audit 181409
  Show dependency treegraph
 
Reported: 2005-12-01 18:25 EST by Paul Moore
Modified: 2009-10-28 09:38 EDT (History)
4 users (show)

See Also:
Fixed In Version: RHBA-2006-0339
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-08-10 17:12:59 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
patch to amtu-1.0.2 which solves the problem (1.05 KB, patch)
2005-12-01 18:27 EST, Paul Moore
no flags Details | Diff

  None (edit)
Description Paul Moore 2005-12-01 18:25:12 EST
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.7.12) Gecko/20050922 Fedora/1.0.7-1.1.fc4 Firefox/1.0.7

Description of problem:
There is a sporadic bug in the AMTU memory separation test which can be seen on IA64 using the following command:

 while amtu; do true; done

Eventually the command will fail because it successfully accessed memory which it believes it should not be able to access.  The problem is the result of a faulty random number generation routine which incorrectly generates a random access within a specified range.

While I have only seen this IA64 it is reasonable to assume that other 64bit platforms would be affected.




Version-Release number of selected component (if applicable):
amtu-1.0.2-2.EL4

How reproducible:
Always

Steps to Reproduce:
1. while amtu; do true; done
  

Actual Results:  Memory Test SUCCESS!
Executing Memory Test...
Executing Memory Separation Test...
value of address: 40600
Memory Separation Test FAILED!

Expected Results:  Executing Memory Test...
Memory Test SUCCESS!
Executing Memory Separation Test...
Memory Separation Test SUCCESS!
Executing Network I/O Tests...
Network I/O Controller Test SUCCESS!
Executing I/O Controller - Disk Test...
I/O Controller - Disk Test SUCCESS!
Executing Supervisor Mode Instructions Test...
Privileged Instruction Test SUCCESS!

Additional info:
Comment 1 Paul Moore 2005-12-01 18:27:31 EST
Created attachment 121721 [details]
patch to amtu-1.0.2 which solves the problem

This patch made against the sources in the source RPM for amtu-1.0.2-2.EL4
fixes the problem.
Comment 2 Steve Grubb 2005-12-05 10:46:17 EST
Paul, was this bug observed on x86_64 or any other 64 bit arch?
Comment 3 Paul Moore 2005-12-05 11:06:28 EST
Linda Knippers ran AMTU on x86_64 in a loop for about 30 minutes and did not see
any problems, however, it is uncertain if this is due to luck or design.  IA64
and x86_64 are the only two 64 bit platforms that I have available which will
run RHEL4.
Comment 4 Steve Grubb 2005-12-05 17:47:04 EST
amtu-1.0.2-4.EL4 was built with this patch applied.
Comment 5 Debora Velarde 2005-12-06 11:50:30 EST
We have been unable to reproduce the problem on pSeries, iSeries, or s390x.
Comment 8 Bob Johnson 2006-04-11 11:57:19 EDT
This issue is on Red Hat Engineering's list of planned work items 
for the upcoming Red Hat Enterprise Linux 4.4 release.  Engineering 
resources have been assigned and barring unforeseen circumstances, Red 
Hat intends to include this item in the 4.4 release.
Comment 12 Red Hat Bugzilla 2006-08-10 17:13:00 EDT
An advisory has been issued which should help the problem
described in this bug report. This report is therefore being
closed with a resolution of ERRATA. For more information
on the solution and/or where to find the updated files,
please follow the link below. You may reopen this bug report
if the solution does not work for you.

http://rhn.redhat.com/errata/RHBA-2006-0339.html

Note You need to log in before you can comment on or make changes to this bug.