Bug 1747737 - packages with conflicts
Summary: packages with conflicts
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: liberation-fonts
Version: 30
Hardware: Unspecified
OS: Linux
high
high
Target Milestone: ---
Assignee: vishal vijayraghavan
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
: 1747785 1748302 (view as bug list)
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2019-09-01 05:28 UTC by Donald O'Dona
Modified: 2019-09-28 00:01 UTC (History)
34 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2019-09-05 11:48:17 UTC
Type: Bug
Embargoed:


Attachments (Terms of Use)

Description Donald O'Dona 2019-09-01 05:28:00 UTC
Description of problem:


Version-Release number of selected component (if applicable):


How reproducible:

 dnf upgrade

Steps to Reproduce:
1.  dnf upgrade

2.
3.

Actual results:
Last metadata expiration check: 0:31:29 ago on Sun 01 Sep 2019 06:48:24 AM CEST.
Dependencies resolved.

 Problem: cannot install both liberation-fonts-1:2.00.5-1.fc30.noarch and liberation-fonts-1:2.00.5-3.fc30.noarch
  - cannot install the best update candidate for package liberation-narrow-fonts-1.07.6-1.fc30.noarch
  - cannot install the best update candidate for package liberation-fonts-1:2.00.5-3.fc30.noarch
================================================================================================================================================================================================================================================ Package                                                        Architecture                                         Version                                                         Repository                                            Size
================================================================================================================================================================================================================================================Skipping packages with conflicts:
(add '--best --allowerasing' to command line to force their upgrade):
 liberation-fonts                                               noarch                                               1:2.00.5-1.fc30                                                 fedora                                               8.0 k

Transaction Summary
================================================================================================================================================================================================================================================Skip  1 Package

Nothing to do.
Complete!


Expected results:
no errors

Additional info:

Comment 1 Marek Blaha 2019-09-02 06:06:37 UTC
It looks like liberation-fonts-1:2.00.5-1.fc30.noarch obsoletes and provides liberation-narrow-fonts but the updated liberation-fonts-1:2.00.5-3.fc30.noarch version does not:

$ dnf repoquery --obsoletes liberation-fonts-1:2.00.5-1.fc30.noarch
liberation-narrow-fonts < 1:2.0.0
$ dnf repoquery --provides liberation-fonts-1:2.00.5-1.fc30.noarch
liberation-fonts = 1:2.00.5-1.fc30
liberation-narrow-fonts = 1:2.00.5-1.fc30

$ dnf repoquery --obsoletes liberation-fonts-1:2.00.5-3.fc30.noarch
$ dnf repoquery --provides liberation-fonts-1:2.00.5-3.fc30.noarch
liberation-fonts = 1:2.00.5-3.fc30

Reassigning to liberation-fonts component to resolve the packaging problem.

You can workaround it by locking liberation-fonts package on older version: # dnf versionlock liberation-fonts

Comment 2 Yaroslav Sidlovsky 2019-09-02 06:49:33 UTC
Same bug: #1747785.

Comment 3 Donald O'Dona 2019-09-02 07:03:37 UTC
# dnf update
skipping packages with conflicts:
(add '--best --allowerasing' to command line to force their upgrade):
 liberation-fonts noarch 1:2.00.5-1.fc30 fedora 8.0 k

# dnf update --best --allowerasing liberation-fonts
Last metadata expiration check: 0:59:12 ago on Mon 02 Sep 2019 08:01:11 AM CEST.
Error: 
 Problem: cannot install the best update candidate for package liberation-fonts-1:2.00.5-3.fc30.noarch
  - cannot install both liberation-fonts-1:2.00.5-1.fc30.noarch and liberation-fonts-1:2.00.5-3.fc30.noarch
  - problem with installed package liberation-narrow-fonts-1.07.6-1.fc30.noarch
  - cannot install the best update candidate for package liberation-narrow-fonts-1.07.6-1.fc30.noarch
(try to add '--skip-broken' to skip uninstallable packages)

# dnf update --best --allowerasing liberation-fonts --skip-broken
Error: 
 Problem: cannot install the best update candidate for package liberation-fonts-1:2.00.5-3.fc30.noarch
  - cannot install both liberation-fonts-1:2.00.5-1.fc30.noarch and liberation-fonts-1:2.00.5-3.fc30.noarch
  - problem with installed package liberation-narrow-fonts-1.07.6-1.fc30.noarch
  - cannot install the best update candidate for package liberation-narrow-fonts-1.07.6-1.fc30.noarch

Comment 4 Marek Blaha 2019-09-02 08:16:33 UTC
May I ask you what version of dnf are you using?

My first thought was, that the provide/obsolete are missing in newer version by a mistake. But in liberation-fonts changelog I found:

* Mon Jun 24 2019 Vishal Vijayraghavan <vvijayra AT redhat DOT com> - 1:2.00.5-3
- Resolves: rhbz#1643920: Removed Obsoletes: %{fontname}-narrow-fonts and Provides: %{fontname}-narrow-fonts macro
- Splitted the font family(mono, sans and serif) into diferrent root font directories

Now the situation is confusing for the dependency solver:

- given the obsolete/provide in the version liberation-fonts-1:2.00.5-1.fc30.noarch, this is the best version of liberation-narrow-fonts package
- at the same time liberation-fonts-1:2.00.5-3.fc30.noarch is the best version of liberation-fonts

this end in solution where two versions of liberation-fonts are about to be installed, which is not viable.
I'm not sure how to solve this situation, but better workaround at the moment is not to use versionlock (as I recommended in comment#1), but exclude liberation-fonts-1:2.00.5-1.fc30.noarch package. E.g. adding

excludepkgs=liberation-fonts-1:2.00.5-1.fc30.noarch

line into [main] section of /etc/dnf/dnf.conf

Comment 5 Yaroslav Sidlovsky 2019-09-02 08:20:42 UTC
$ env LANGUAGE=en dnf --version                                                                                                                                                                                                                              0.3s (0) 11:19:58
4.2.7
  Installed: dnf-0:4.2.7-2.fc30.noarch at Вт 30 июл 2019 09:40:08
  Built    : Fedora Project at Вт 23 июл 2019 07:10:30

  Installed: rpm-0:4.14.2.1-5.fc30.x86_64 at Пн 02 сен 2019 05:58:34
  Built    : Fedora Project at Чт 29 авг 2019 10:46:16

Comment 6 Donald O'Dona 2019-09-02 16:48:26 UTC
env LANGUAGE=en dnf --version        
4.2.7
  Installed: dnf-0:4.2.7-2.fc30.noarch at Tue 30 Jul 2019 10:59:54 AM GMT
  Built    : Fedora Project at Tue 23 Jul 2019 07:10:30 AM GMT

  Installed: rpm-0:4.14.2.1-5.fc30.x86_64 at Mon 02 Sep 2019 05:26:38 AM GMT
  Built    : Fedora Project at Thu 29 Aug 2019 10:46:16 AM GMT

Comment 7 Edouard Bourguignon 2019-09-03 05:31:23 UTC
same here if wine is installed can't upgrade without error:

LANG=C dnf --version
4.2.7
  Installed: dnf-0:4.2.7-2.fc30.noarch at Sat Aug 24 12:35:09 2019
  Built    : Fedora Project at Tue Jul 23 07:10:30 2019

  Installed: rpm-0:4.14.2.1-5.fc30.x86_64 at Sun Sep  1 09:32:22 2019
  Built    : Fedora Project at Thu Aug 29 10:46:16 2019

Comment 8 Michal Jaegermann 2019-09-03 14:38:51 UTC
Not that surprisingly the same problem hits liberation-fonts-2.00.3-1.fc29 as well.  This cannot be installed even with '--allowerasing' present.

Comment 9 Kalev Lember 2019-09-03 15:28:13 UTC
I think a simple solution to this would be to bump liberation-narrow-fonts epoch to 2, to make sure that the liberation-narrow-fonts EVR compares higher to 1:2.00.5-1.fc30 that's provided by liberation-fonts.

Comment 10 Jens Petersen 2019-09-04 07:53:11 UTC
(In reply to Kalev Lember from comment #9)
> I think a simple solution to this would be to bump liberation-narrow-fonts
> epoch to 2, to make sure that the liberation-narrow-fonts EVR compares
> higher to 1:2.00.5-1.fc30 that's provided by liberation-fonts.

Yes +1

Comment 11 Albert 2019-09-04 15:44:54 UTC
got same issue here

 Problem: cannot install both liberation-fonts-1:2.00.5-1.fc30.noarch and liberation-fonts-1:2.00.5-3.fc30.noarch

 >  env LANGUAGE=en dnf --version 
4.2.7
  Installed: dnf-0:4.2.7-2.fc30.noarch at Wed 04 Sep 2019 06:34:29 AM GMT
  Built    : Fedora Project at Tue 23 Jul 2019 07:10:30 AM GMT

  Installed: rpm-0:4.14.2.1-5.fc30.x86_64 at Wed 04 Sep 2019 06:31:19 AM GMT
  Built    : Fedora Project at Thu 29 Aug 2019 10:46:16 AM GMT

Comment 12 Parag Nemade 2019-09-04 16:31:35 UTC
*** Bug 1748302 has been marked as a duplicate of this bug. ***

Comment 13 Parag Nemade 2019-09-04 16:32:26 UTC
*** Bug 1747785 has been marked as a duplicate of this bug. ***

Comment 14 love58900 2019-09-05 04:53:37 UTC
You can try:

rpm -e --nodeps liberation-narrow-fonts-1.07.6-1.fc30.noarch

It should remove the package and not the dependencies. The issue looks like it's because the package names are different but the install location is the same.


SOURCE: https://www.reddit.com/r/Fedora/comments/cxzcwy/cant_upgrade_a_package/

Comment 15 Fedora Update System 2019-09-05 08:41:35 UTC
FEDORA-2019-2b29cee6f9 has been submitted as an update to Fedora 29. https://bodhi.fedoraproject.org/updates/FEDORA-2019-2b29cee6f9

Comment 16 Fedora Update System 2019-09-05 08:41:39 UTC
FEDORA-2019-61d9c21e30 has been submitted as an update to Fedora 30. https://bodhi.fedoraproject.org/updates/FEDORA-2019-61d9c21e30

Comment 17 Gergely Gombos 2019-09-05 09:08:23 UTC
Thanks for the fix, it's working! Let's test and give it some karma in Bodhi so that it can quickly be pushed to stable.

Comment 18 Fedora Update System 2019-09-05 10:52:13 UTC
liberation-narrow-fonts-1.07.6-2.fc31 has been pushed to the Fedora 31 testing repository. If problems still persist, please make note of it in this bug report.
See https://fedoraproject.org/wiki/QA:Updates_Testing for
instructions on how to install test updates.
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2019-c3d484d6c4

Comment 19 Fedora Update System 2019-09-05 11:48:17 UTC
liberation-narrow-fonts-1.07.6-2.fc30 has been pushed to the Fedora 30 stable repository. If problems still persist, please make note of it in this bug report.

Comment 20 Fedora Update System 2019-09-05 13:06:36 UTC
liberation-narrow-fonts-1.07.6-2.fc29 has been pushed to the Fedora 29 testing repository. If problems still persist, please make note of it in this bug report.
See https://fedoraproject.org/wiki/QA:Updates_Testing for
instructions on how to install test updates.
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2019-2b29cee6f9

Comment 21 Donald O'Dona 2019-09-05 20:44:13 UTC
it seems to be fixed so far. Thanks RH people!

Comment 22 Alexandre Ducastaing 2019-09-06 06:05:55 UTC
It is fixed for me too. Thanks to Fedora Team!

Comment 23 Albert 2019-09-12 06:11:33 UTC
Different version, same issue ?

Dependencies resolved.

 Problem: cannot install both liberation-fonts-1:2.00.3-1.fc29.noarch and liberation-fonts-1:2.00.5-2.fc29.noarch
  - cannot install the best update candidate for package liberation-narrow-fonts-1.07.5-1.fc29.noarch
  - cannot install the best update candidate for package liberation-fonts-1:2.00.5-2.fc29.noarch
=============================================================================================================================================================================================================================================
 Package                                                       Architecture                                        Version                                                         Repository                                           Size
=============================================================================================================================================================================================================================================
Skipping packages with conflicts:
(add '--best --allowerasing' to command line to force their upgrade):
 liberation-fonts                                              noarch                                              1:2.00.3-1.fc29                                                 fedora                                              7.8 k

Transaction Summary
=============================================================================================================================================================================================================================================
Skip  1 Package

Nothing to do.
Complete!

Comment 24 Michal Jaegermann 2019-09-12 14:51:25 UTC
(In reply to Albert Szostkiewicz from comment #23)
> Different version, same issue ?
> 
> Dependencies resolved.
> 
>  Problem: cannot install both liberation-fonts-1:2.00.3-1.fc29.noarch and
> liberation-fonts-1:2.00.5-2.fc29.noarch
>   - cannot install the best update candidate for package
> liberation-narrow-fonts-1.07.5-1.fc29.noarch

According to comment #20 from 2019-09-05 this trouble is resolved by version 1.07.6-2 while "regular" repositories for fc29 are still offering only 1.07.5-1.  While 1.07.6-2 does fix this the update is apparently still stuck up in "channels".

Comment 25 Fedora Update System 2019-09-12 21:34:24 UTC
liberation-narrow-fonts-1.07.6-2.fc29 has been pushed to the Fedora 29 stable repository. If problems still persist, please make note of it in this bug report.

Comment 26 Fedora Update System 2019-09-28 00:01:49 UTC
liberation-narrow-fonts-1.07.6-2.fc31 has been pushed to the Fedora 31 stable repository. If problems still persist, please make note of it in this bug report.


Note You need to log in before you can comment on or make changes to this bug.