Bug 174778 - 32 serial ports show up on a system with 0 serial ports enabled
32 serial ports show up on a system with 0 serial ports enabled
Status: CLOSED CANTFIX
Product: Fedora
Classification: Fedora
Component: kernel (Show other bugs)
5
i686 Linux
medium Severity medium
: ---
: ---
Assigned To: Dave Jones
Brian Brock
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2005-12-01 20:23 EST by Jason
Modified: 2015-01-04 17:23 EST (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-12-02 00:59:36 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Jason 2005-12-01 20:23:05 EST
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.8) Gecko/20051129 Fedora/1.5-1 Firefox/1.5

Description of problem:
I was looking in my dmesg output and I found the following:
Serial: 8250/16550 driver $Revision: 1.90 $ 32 ports, IRQ sharing enabled

I looked in my /dev directory and I found 32 ttyS nodes there.  My question is why are there any ttyS nodes in /dev?  My system has two serial ports, both of which are disabled in the bios.  I no longer have a modem since I switched to DSL.  When I did have a modem it was listed as being /dev/ttyS14 (internal PCI modem from Actiontec).

Version-Release number of selected component (if applicable):
all 2.6 kernels

How reproducible:
Always

Steps to Reproduce:
1.  install FC3, FC4, or FC5T1
2.  look in /dev and see 32 nodes
3.  look at dmesg and see the driver report 32 ports
  

Actual Results:  the system says there are 32 serial ports on a system with 0 serial ports enabled.

Expected Results:  There should be zero serial ports reported by the kernel.

Additional info:
Comment 1 Dave Jones 2005-12-02 00:59:36 EST
we can't prove the existance of a port or not, and they don't generate
interrupts when you plug something into them, so we can't create them
dynamically. So we have to resort to registering the maximum number supported by
a serial driver.
Comment 2 Jason 2005-12-02 20:39:48 EST
I mean this with the utmost respect, but that does not sound quite right.  I
know some people will dislike what I say next but here it goes:  windows can do
this.    I am not a kernel programmer so I don't what it would take to begin a
project like this, but if windows can do it why not the kernel?  I will bow to
the expects but I would like to know why it cannot be done so I can learn.

Note You need to log in before you can comment on or make changes to this bug.