Bug 174784 - Cannot mount partition that is not on the same disk as root
Cannot mount partition that is not on the same disk as root
Status: CLOSED NOTABUG
Product: Fedora
Classification: Fedora
Component: autofs (Show other bugs)
5
x86_64 Linux
medium Severity medium
: ---
: ---
Assigned To: Jeffrey Moyer
Brock Organ
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2005-12-01 23:28 EST by Igor Miletic
Modified: 2007-11-30 17:11 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-02-23 09:19:53 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Output of dev directory (1.40 KB, text/plain)
2005-12-02 10:09 EST, Igor Miletic
no flags Details
Strace output of the mount command (7.05 KB, text/plain)
2005-12-02 10:10 EST, Igor Miletic
no flags Details

  None (edit)
Description Igor Miletic 2005-12-01 23:28:10 EST
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux x86_64; en-US; rv:1.8) Gecko/20051129 Fedora/1.5-1 Firefox/1.5

Description of problem:
When booting, or trying to mount partition that is not on the same hard drive as root partition, I am getting message 
[root@localhost ~]# mount /dev/sda2 /tmp/home/
mount: /dev/sda2 already mounted or /tmp/home/ busy

I can not find in mtab that /dev/sda2 is mounted anywhere, and I am not aware that any other program is making in busy in any sense.

Problem gets worse when /boot partition is not on the same disk as root. Which means that I cannot upgrade kernel.

All partitions on sda are ext3, besides swap partition.
sdb disk mounts ok (actually only root is on this partition and LVM partition).
It is interesting that grub is able to read boot partition, but once I am logged into system boot is not mounted. Similar story for any other partition from /sda disk (including swap, it stops on swapon during boot but Ctrl+C makes system skip this step).




Version-Release number of selected component (if applicable):
autofs-4.1.4-14

How reproducible:
Always

Steps to Reproduce:
1.Start computer
2.Try to mount any partition
3.You get error message "already mounted or busy"
  

Actual Results:  I got error message
[root@localhost ~]# mount /dev/sda2 /tmp/home/
mount: /dev/sda2 already mounted or /tmp/home/ busy

Expected Results:  Partitions should be mounted.

Additional info:
Comment 1 Jeffrey Moyer 2005-12-02 07:43:28 EST
first off, I don't think this is an autofs problem, but I'll help you narrow it
down further.

Please post the contents of /proc/mounts, /etc/sysconfig/autofs, and the output
from "service autofs status".
Comment 2 Igor Miletic 2005-12-02 09:38:36 EST
I am not sure where is bug coming from so I choose autofs only because it has
something to do with mounting ;).

cat /proc/mounts

rootfs / rootfs rw 0 0
/dev/root / ext3 rw,data=ordered 0 0
/dev /dev tmpfs rw 0 0
/proc /proc proc rw,nodiratime 0 0
/sys /sys sysfs rw 0 0
none /selinux selinuxfs rw 0 0
/proc/bus/usb /proc/bus/usb usbfs rw 0 0
/dev/devpts /dev/pts devpts rw 0 0
/dev/shm /dev/shm tmpfs rw 0 0
none /proc/sys/fs/binfmt_misc binfmt_misc rw 0 0
sunrpc /var/lib/nfs/rpc_pipefs rpc_pipefs rw 0 0
automount(pid2654) /net autofs rw 0 0


cat /etc/sysconfig/autofs
# Define custom options in /etc/sysconfig/autofs
# Use LOCALOPTIONS for defining variables, e.g. OSREL
# Use DAEMONOPTIONS to define the unmount timeout
# Define UNDERSCORETODOT as 1 to convert 
#     auto_home to auto.home and auto_mnt to auto.mnt
# Mount options, e.g. rsize=8192, should go in auto.master or
#     the auto_* map entry for a specific mount point
#
LOCALOPTIONS=""
DAEMONOPTIONS="--timeout=60"

#  UNDERSCORETODOT changes auto_home to auto.home and auto_mnt to auto.mnt
UNDERSCORETODOT=1
DISABLE_DIRECT=1

# Using a good number of maps can cause autofs to take
# some time to exit. If you get init script stop fails
# but find that a little while latter it's gone increase
# this value.
DAEMON_EXIT_WAIT=10





Output of "service autofs status"

Configured Mount Points:
------------------------
/usr/sbin/automount --timeout=60 /net program /etc/auto.net 

Active Mount Points:
--------------------
/usr/sbin/automount --timeout=60 /net program /etc/auto.net
Comment 3 Jeffrey Moyer 2005-12-02 09:56:03 EST
OK, this is definitely not autofs.

Can you also post the output from "ls /dev"?

It might be useful to get the strace output from your mount command:

# strace mount /dev/sda2 /tmp/home >& /tmp/mount.strace

attach the resulting file.

One other question: is this from a fresh install?  If not, what was the last
thing you changed?
Comment 4 Igor Miletic 2005-12-02 10:09:45 EST
Created attachment 121754 [details]
Output of dev directory

Output of dev directory
Comment 5 Igor Miletic 2005-12-02 10:10:46 EST
Created attachment 121755 [details]
Strace output of the mount command

Strace output of the mount command
Comment 6 Igor Miletic 2005-12-02 10:12:01 EST
This is fresh install, no changes at all. 

I should mention that sda disk has fedora core 3 (not 64-bit one) on it, but I
would expect that it would mount it anyways.

output of the dev directory is in attached file dev.output

Strace output is in mount.strace attached as well.
Comment 7 Jeffrey Moyer 2005-12-02 10:19:02 EST
please run e2label on /dev/sda2 and post the output
Comment 8 Igor Miletic 2005-12-02 10:26:44 EST
e2label /dev/sda2
/

e2label /dev/sdb7
/1

/dev/sda2 is root for FC3
/dev/sdb7 is root for FC5

also

e2label /dev/sda1
/boot1

This one is very important for me :). /dev/sda1 was formated during instalation
of FC5 (as well as /dev/sdb7).
Comment 9 Jeffrey Moyer 2005-12-02 10:32:17 EST
what does /dev/root point to?  "ls -l /dev/root"
Comment 10 Igor Miletic 2005-12-02 10:37:45 EST
ls -l /dev/root
brw------- 1  root root 8, 23 Dec  2 04:29 /dev/root

To itself?
Comment 11 Jeffrey Moyer 2005-12-02 10:46:29 EST
Ok, I'm perplexed.  /dev/root is the same as /dev/sdb7 (major 8, minor 23), as
you suspected.  I'll have to think about this some more.
Comment 12 Igor Miletic 2005-12-03 23:49:40 EST
Ok,
I still don't know what is the problem, but it appears on i386 version FC5 test1
as well.

However, if anyone is interested, workaround is to swap hard drives physically
(i.e. one that was sda becomes sdb and vice versa). Then in bios set to boot
from sdb drive, in other words, swap primary and secondary hard drives.
Comment 13 Igor Miletic 2006-01-30 21:43:37 EST
It seems that problem was bad blkid.tab file. It had wrong hard drive data in it.

Once I removed it and repeated "mount -a" everything worked fine.
Comment 14 Igor Miletic 2006-02-23 09:19:53 EST
I did not see this one in fc5test3. I think it is safe to close it.

Note You need to log in before you can comment on or make changes to this bug.