Bug 1747885 - [UPDATE] undercloud update failed with error "ERROR configuring mysql"
Summary: [UPDATE] undercloud update failed with error "ERROR configuring mysql"
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat OpenStack
Classification: Red Hat
Component: openstack-tripleo-heat-templates
Version: 15.0 (Stein)
Hardware: Unspecified
OS: Unspecified
urgent
urgent
Target Milestone: rc
: 15.0 (Stein)
Assignee: RHOS Maint
QA Contact: Raviv Bar-Tal
URL:
Whiteboard:
: 1748361 1750937 (view as bug list)
Depends On:
Blocks: 1727808 1748361
TreeView+ depends on / blocked
 
Reported: 2019-09-02 08:12 UTC by Raviv Bar-Tal
Modified: 2020-03-05 17:18 UTC (History)
13 users (show)

Fixed In Version: openstack-tripleo-heat-templates-10.6.1-0.20190905170437.b33b839.el8ost
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
: 1748361 (view as bug list)
Environment:
Last Closed: 2019-09-21 11:24:31 UTC
Target Upstream Version:


Attachments (Terms of Use)
undercloud log (818.41 KB, text/plain)
2019-09-02 08:12 UTC, Raviv Bar-Tal
no flags Details


Links
System ID Private Priority Status Summary Last Updated
OpenStack gerrit 679793 0 'None' MERGED container-puppet: run podman rm with --storage 2020-03-04 10:38:19 UTC
Red Hat Product Errata RHEA-2019:2811 0 None None None 2019-09-21 11:25:34 UTC

Description Raviv Bar-Tal 2019-09-02 08:12:45 UTC
Created attachment 1610684 [details]
undercloud log

Description of problem:
undercloud update failed with error "ERROR configuring mysql"

Version-Release number of selected component (if applicable):


How reproducible:
install osp15 beta and try to update to passed_phasse2 (currently RHOS_TRUNK-15.0-RHEL-8-20190829)

Steps to Reproduce:
1.
2.
3.

Actual results:
undercloud updaete failes 

Expected results:


Additional info:
attached unedrcloud_update.log

Comment 1 Sofer Athlan-Guyot 2019-09-02 13:09:33 UTC
Hi,

so we remove the container there:

 2019-09-01 12:40:19 |         "2019-09-01 12:39:18,964 INFO: 481318 -- Removing container: container-puppet-mysql",

and then:

2019-09-01 12:40:19 |         "2019-09-01 12:39:47,157 ERROR: 481318 -- ['/usr/bin/podman', 'run', '--user', 'root', '--name', 'container-puppet-mysql', '--env', 'PUPPET_TAGS=file,file_line,concat,augeas,cron,file', '--env', 'NAME=mysql', '--env', 'HOSTNAME=undercloud-0', '--env', 'NO_ARCHIVE=', '--env', 'STEP=6', '--env', 'NET_HOST=true', '--log-driver', 'json-file', '--volume', '/etc/localtime:/etc/localtime:ro', '--volume', '/tmp/tmp4qominnc:/etc/config.pp:ro', '--volume', '/etc/puppet/:/tmp/puppet-etc/:ro', '--volume', '/etc/pki/ca-trust/extracted:/etc/pki/ca-trust/extracted:ro', '--volume', '/etc/pki/tls/certs/ca-bundle.crt:/etc/pki/tls/certs/ca-bundle.crt:ro', '--volume', '/etc/pki/tls/certs/ca-bundle.trust.crt:/etc/pki/tls/certs/ca-bundle.trust.crt:ro', '--volume', '/etc/pki/tls/cert.pem:/etc/pki/tls/cert.pem:ro', '--volume', '/var/lib/config-data:/var/lib/config-data/:rw', '--volume', '/var/lib/container-puppet/puppetlabs/facter.conf:/etc/puppetlabs/facter/facter.conf:ro', '--volume', '/var/lib/container-puppet/puppetlabs/:/opt/puppetlabs/:ro', '--volume', '/dev/log:/dev/log:rw', '--log-opt', 'path=/var/log/containers/stdouts/container-puppet-mysql.log', '--security-opt', 'label=disable', '--volume', '/usr/share/openstack-puppet/modules/:/usr/share/openstack-puppet/modules/:ro', '--entrypoint', '/var/lib/container-puppet/container-puppet.sh', '--net', 'host', '--volume', '/etc/hosts:/etc/hosts:ro', '--volume', '/var/lib/container-puppet/container-puppet.sh:/var/lib/container-puppet/container-puppet.sh:ro', '192.168.24.1:8787/rhosp15/openstack-mariadb:20190829.2'] run failed after error creating container storage: the container name \"container-puppet-mysql\" is already in use by \"4b9ae8aa7f5914d25e70646e5bb6e2cf3664ebc525ddc8ea1c8d8dbd75a51cf2\". You have to remove that container to be able to reuse that name.: that name is already in use",
2019-09-01 12:40:19 |         " attempt(s): 1",
2019-09-01 12:40:19 |         "2019-09-01 12:39:47,157 WARNING: 481318 -- Retrying running container: mysql",
2019-09-01 12:40:19 |         "2019-09-01 12:39:55,111 ERROR: 481318 -- ['/usr/bin/podman', 'start', '-a', 'container-puppet-mysql'] run failed after unable to find container container-puppet-mysql: no container with name or ID container-puppet-mysql found: no such container",
2019-09-01 12:40:19 |         " attempt(s): 2",
2019-09-01 12:40:19 |         "2019-09-01 12:39:55,111 WARNING: 481318 -- Retrying running container: mysql",
2019-09-01 12:40:19 |         "2019-09-01 12:39:58,236 ERROR: 481318 -- ['/usr/bin/podman', 'start', '-a', 'container-puppet-mysql'] run failed after unable to find container container-puppet-mysql: no container with name or ID container-puppet-mysql found: no such container",
2019-09-01 12:40:19 |         " attempt(s): 3",
2019-09-01 12:40:19 |         "2019-09-01 12:39:58,236 WARNING: 481318 -- Retrying running container: mysql",
2019-09-01 12:40:19 |         "2019-09-01 12:39:58,236 ERROR: 481318 -- Failed running container for mysql",


we are not able to create it because the name is already used and then start fails because it cannot find it.  Puzzling logs.

Comment 7 Raviv Bar-Tal 2019-09-03 12:31:17 UTC
*** Bug 1748361 has been marked as a duplicate of this bug. ***

Comment 18 Sofer Athlan-Guyot 2019-09-18 06:23:18 UTC
*** Bug 1750937 has been marked as a duplicate of this bug. ***

Comment 20 errata-xmlrpc 2019-09-21 11:24:31 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHEA-2019:2811


Note You need to log in before you can comment on or make changes to this bug.